
<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
<head>

<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<title>Obituary: William E. Alexander Jr. - Portland Press Herald</title>
<link rel="icon" type="image/png" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/images/favicon.png" />
<link rel="apple-touch-icon" type="image/png" href="https://multifiles.pressherald.com/uploads/sites/4/2014/06/apple-touch-icon-iphone.png" />
<link rel="apple-touch-icon" type="image/png" sizes="72x72" href="https://multifiles.pressherald.com/uploads/sites/4/2014/06/apple-touch-icon-ipad.png" />
<link rel="apple-touch-icon" type="image/png" sizes="114x114" href="https://multifiles.pressherald.com/uploads/sites/4/2014/06/apple-touch-icon-iphone-retina-display.png" />

<link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.3.1/css/all.css" integrity="sha384-mzrmE5qonljUremFsqc01SB46JvROS7bZs3IO2EmfFsd15uHvIt+Y8vEf7N7fWAU" crossorigin="anonymous">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<script type="text/javascript">
var gform;gform||(document.addEventListener("gform_main_scripts_loaded",function(){gform.scriptsLoaded=!0}),window.addEventListener("DOMContentLoaded",function(){gform.domLoaded=!0}),gform={domLoaded:!1,scriptsLoaded:!1,initializeOnLoaded:function(o){gform.domLoaded&&gform.scriptsLoaded?o():!gform.domLoaded&&gform.scriptsLoaded?window.addEventListener("DOMContentLoaded",o):document.addEventListener("gform_main_scripts_loaded",o)},hooks:{action:{},filter:{}},addAction:function(o,n,r,t){gform.addHook("action",o,n,r,t)},addFilter:function(o,n,r,t){gform.addHook("filter",o,n,r,t)},doAction:function(o){gform.doHook("action",o,arguments)},applyFilters:function(o){return gform.doHook("filter",o,arguments)},removeAction:function(o,n){gform.removeHook("action",o,n)},removeFilter:function(o,n,r){gform.removeHook("filter",o,n,r)},addHook:function(o,n,r,t,i){null==gform.hooks[o][n]&&(gform.hooks[o][n]=[]);var e=gform.hooks[o][n];null==i&&(i=n+"_"+e.length),gform.hooks[o][n].push({tag:i,callable:r,priority:t=null==t?10:t})},doHook:function(n,o,r){var t;if(r=Array.prototype.slice.call(r,1),null!=gform.hooks[n][o]&&((o=gform.hooks[n][o]).sort(function(o,n){return o.priority-n.priority}),o.forEach(function(o){"function"!=typeof(t=o.callable)&&(t=window[t]),"action"==n?t.apply(null,r):r[0]=t.apply(null,r)})),"filter"==n)return r[0]},removeHook:function(o,n,t,i){var r;null!=gform.hooks[o][n]&&(r=(r=gform.hooks[o][n]).filter(function(o,n,r){return!!(null!=i&&i!=o.tag||null!=t&&t!=o.priority)}),gform.hooks[o][n]=r)}});
</script>


<meta name="google-site-verification" content="QWs9pxQP8fwo2-nR5mWopc6qCK2D3920f7bl-U-zkso" />


<meta name="apple-itunes-app" content="app-id=951845858">

<script type='text/javascript' src='https://loader-cdn.azureedge.net/prod/masthead/loader.min.js'></script>

<script type="text/javascript">
		var _sf_async_config = _sf_async_config || {};

		/** CONFIGURATION START **/
		_sf_async_config.uid = 64520; // ACCOUNT NUMBER
		_sf_async_config.domain = 'pressherald.com'; // DOMAIN
		_sf_async_config.flickerControl = false;
		_sf_async_config.useCanonical = true;
		/** CONFIGURATION END **/

		var _sf_startpt = (new Date()).getTime();
	</script>
<script async src="//static.chartbeat.com/js/chartbeat_mab.js"></script>


<style>.async-hide { opacity: 0 !important} </style>
<script>(function(a,s,y,n,c,h,i,d,e){s.className+=' '+y;h.start=1*new Date;
        h.end=i=function(){s.className=s.className.replace(RegExp(' ?'+y),'')};
        (a[n]=a[n]||[]).hide=h;setTimeout(function(){i();h.end=null},c);h.timeout=c;
        })(window,document.documentElement,'async-hide','dataLayer',4000,
        {'GTM-TZKX8X':true});</script>

<script type="text/javascript"> (function(userDB) {
	var initialized;
	var done = function() {
	    if (!initialized) {
	        initialized = true;
	        timerId && clearTimeout(timerId);
	        if (window.Connext && window.Connext.Run) {
	            window.Connext.Run();
	        } else {
	            // wait for Connext to load
	            var timerIdPoll = setInterval(function() {
	                if (window.Connext && window.Connext.Run) {
	                    clearInterval(timerIdPoll);
	                    window.Connext.Run();
	                }
	            }, 500);
	        }
	    }
	};
	var timerId = setTimeout(function() {
	    done();
	}, 3000);
	(window.top._matherq = window.top._matherq || []).push(['getTracker', function(tracker) {
	tracker.setPaywall('mg2');
	if (userDB) {
	    tracker.getUserDBSegment({}, function(userDBData) {
	        done();
	    });
	} else {
	    done();
	}
	}]);
	})(true);
	</script>
<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<link rel="canonical" href="https://www.pressherald.com/2022/04/21/obituarywilliam-e-alexander-jr/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Obituary: William E. Alexander Jr." />
<meta property="og:description" content="William E. Alexander Jr. 1943 - 2022 ALBANY, N.Y. - William Ellsworth &quot;Alex&quot; Alexander, Jr. passed away suddenly of natural causes ..." />
<meta property="og:url" content="https://www.pressherald.com/2022/04/21/obituarywilliam-e-alexander-jr/" />
<meta property="og:site_name" content="Press Herald" />
<meta property="article:publisher" content="https://www.facebook.com/pressherald" />
<meta property="article:published_time" content="2022-04-21T05:01:01+00:00" />
<meta property="og:image" content="https://multifiles.pressherald.com/uploads/sites/4/2022/04/0346734.jpg" />
<meta property="og:image:width" content="300" />
<meta property="og:image:height" content="450" />
<meta property="og:image:type" content="image/jpeg" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:creator" content="@pressherald" />
<meta name="twitter:site" content="@pressherald" />
<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.pressherald.com/#website","url":"https://www.pressherald.com/","name":"Press Herald","description":"","publisher":{"@id":"https://www.pressherald.com/#organization"},"potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.pressherald.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.pressherald.com/2022/04/21/obituarywilliam-e-alexander-jr/#primaryimage","inLanguage":"en-US","url":"https://multifiles.pressherald.com/uploads/sites/4/2022/04/0346734.jpg","contentUrl":"https://multifiles.pressherald.com/uploads/sites/4/2022/04/0346734.jpg","width":300,"height":450,"caption":"William E. Alexander Jr."},{"@type":"WebPage","@id":"https://www.pressherald.com/2022/04/21/obituarywilliam-e-alexander-jr/#webpage","url":"https://www.pressherald.com/2022/04/21/obituarywilliam-e-alexander-jr/","name":"Obituary: William E. Alexander Jr. - Portland Press Herald","isPartOf":{"@id":"https://www.pressherald.com/#website"},"primaryImageOfPage":{"@id":"https://www.pressherald.com/2022/04/21/obituarywilliam-e-alexander-jr/#primaryimage"},"datePublished":"2022-04-21T05:01:01+00:00","dateModified":"2022-04-21T05:01:01+00:00","breadcrumb":{"@id":"https://www.pressherald.com/2022/04/21/obituarywilliam-e-alexander-jr/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.pressherald.com/2022/04/21/obituarywilliam-e-alexander-jr/"]}]},{"@type":"BreadcrumbList","@id":"https://www.pressherald.com/2022/04/21/obituarywilliam-e-alexander-jr/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.pressherald.com/"},{"@type":"ListItem","position":2,"name":"Obituary: William E. Alexander Jr."}]},{"@type":"NewsArticle","@id":"https://www.pressherald.com/2022/04/21/obituarywilliam-e-alexander-jr/#article","isPartOf":{"@id":"https://www.pressherald.com/2022/04/21/obituarywilliam-e-alexander-jr/#webpage"},"author":{"@id":"https://www.pressherald.com/#/schema/person/7c51b1f38a8dc37bd5abb094cd630f3e"},"headline":"Obituary: William E. Alexander Jr.","datePublished":"2022-04-21T05:01:01+00:00","dateModified":"2022-04-21T05:01:01+00:00","mainEntityOfPage":{"@id":"https://www.pressherald.com/2022/04/21/obituarywilliam-e-alexander-jr/#webpage"},"wordCount":323,"commentCount":0,"publisher":{"@id":"https://www.pressherald.com/#organization"},"image":{"@id":"https://www.pressherald.com/2022/04/21/obituarywilliam-e-alexander-jr/#primaryimage"},"thumbnailUrl":"https://multifiles.pressherald.com/uploads/sites/4/2022/04/0346734.jpg","articleSection":["Obituaries","Times Record","Times Record Obituaries"],"inLanguage":"en-US","potentialAction":[{"@type":"CommentAction","name":"Comment","target":["https://www.pressherald.com/2022/04/21/obituarywilliam-e-alexander-jr/#respond"]}]},{"@type":"Person","@id":"https://www.pressherald.com/#/schema/person/7c51b1f38a8dc37bd5abb094cd630f3e","name":"obituaries","image":{"@type":"ImageObject","@id":"https://www.pressherald.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/ad07f160ea44e6c17d707b520713d2a9?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/ad07f160ea44e6c17d707b520713d2a9?s=96&d=mm&r=g","caption":"obituaries"},"url":"https://www.pressherald.com/author/obituaries/"}]}</script>

<link rel='dns-prefetch' href='//cdnjs.cloudflare.com' />
<link rel='dns-prefetch' href='//securepubads.g.doubleclick.net' />
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//multifiles.pressherald.com' />
<link rel="alternate" type="application/rss+xml" title="Press Herald &raquo; Obituary: William E. Alexander Jr. Comments Feed" href="https://www.pressherald.com/2022/04/21/obituarywilliam-e-alexander-jr/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.pressherald.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.9.3"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='elasticpress-related-posts-block-css' href='https://www.pressherald.com/wp-content/plugins/elasticpress/dist/css/related-posts-block-styles.min.css?ver=3.6.6' type='text/css' media='all' />
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='smugmugButtonCss-css' href='https://www.pressherald.com/wp-content/plugins/mtm-smugmug-buy-now/assets/css/mtm-smugmug-link.css?ver=1646825190' type='text/css' media='all' />
<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/css/vendor/flexslider.css?ver=2.2.0" as="style" onload="this.onload=null;this.rel='stylesheet'">
<noscript><link rel="stylesheet" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/css/vendor/flexslider.css?ver=2.2.0" type="text/css" media="all"></noscript>
<link rel='stylesheet' id='bxslider-css' href='https://www.pressherald.com/wp-content/themes/mainetoday/assets/css/vendor/jquery.bxslider.css?ver=4.0' type='text/css' media='all' />
<link rel='stylesheet' id='slick-css' href='https://www.pressherald.com/wp-content/themes/mainetoday/assets/css/vendor/slick/slick.css?ver=5.9.3' type='text/css' media='all' />
<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/css/vendor/slick/slick-lightbox.css?ver=5.9.3" as="style" onload="this.onload=null;this.rel='stylesheet'">
<noscript><link rel="stylesheet" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/css/vendor/slick/slick-lightbox.css?ver=5.9.3" type="text/css" media="all"></noscript>
<link rel='stylesheet' id='ticker-css' href='https://www.pressherald.com/wp-content/themes/mainetoday/assets/css/vendor/ticker-style.css?ver=1530269455' type='text/css' media='all' />
<link rel="preload" href="https://maxcdn.bootstrapcdn.com/font-awesome/4.5.0/css/font-awesome.min.css?ver=5.9.3" as="style" onload="this.onload=null;this.rel='stylesheet'">
<noscript><link rel="stylesheet" href="https://maxcdn.bootstrapcdn.com/font-awesome/4.5.0/css/font-awesome.min.css?ver=5.9.3" type="text/css" media="all"></noscript>
<!--[if lt IE 9]>
<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/css/ie8.css?ver=1530269455" as="style" onload="this.onload=null;this.rel='stylesheet'">
<noscript><link rel="stylesheet" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/css/ie8.css?ver=1530269455" type="text/css" media="all"></noscript>
<![endif]-->
<link rel='stylesheet' id='wpb-google-fonts-roboto-css' href='https://fonts.googleapis.com/css?family=Roboto+Slab&#038;ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='wpb-google-fonts-lato-css' href='https://fonts.googleapis.com/css?family=Lato&#038;ver=5.9.3' type='text/css' media='all' />
<link rel='stylesheet' id='elasticpress-autosuggest-css' href='https://www.pressherald.com/wp-content/plugins/elasticpress/dist/css/autosuggest-styles.min.css?ver=3.6.6' type='text/css' media='all' />
<link rel='stylesheet' id='mainetoday-css' href='https://www.pressherald.com/wp-content/themes/mainetoday/assets/css/mainetoday.min.css?ver=1650452226' type='text/css' media='all' />
<link rel='stylesheet' id='mainetoday_pressherald-css' href='https://www.pressherald.com/wp-content/themes/mainetoday-pressherald/assets/css/mtm-child.min.css?ver=1646115357' type='text/css' media='all' />
<style type="text/css">
					</style>
<script type='text/javascript' id='handlebars-js-extra'>
/* <![CDATA[ */
var sectionFrontData = {"isFront":""};
var paywall = {"global":{"count":"4","promo":"","returnPath":"https:\/\/www.pressherald.com\/wp-content\/themes\/mainetoday\/returnpath.php","currentPage":"https:\/\/www.pressherald.com\/?p=6529775","resetCode":"reset817","bypassCode":"MaYTh34ce18","faq":"https:\/\/myaccount.pressherald.com\/faq.php","isSingle":1,"premium":0,"premiumSharing":""},"status":"enabled","adBlockLinks":["http:\/\/dev.mainetodaymedia.com\/2017-incognito\/load.html"],"adBlockEnabled":"","stubLinks":"\/\/dev.mainetodaymedia.com\/devtools\/2021-paywall\/normal0621-pph.html","privateBlockEnabled":"","privateURLs":"\/\/dev.mainetodaymedia.com\/paywall\/subscriber\/subonly.html","category_list":[{"term_id":34115,"name":"Obituaries","slug":"obituaries","term_group":0,"term_taxonomy_id":34343,"taxonomy":"category","description":"","parent":0,"count":13857,"filter":"raw","cat_ID":34115,"category_count":13857,"category_description":"","cat_name":"Obituaries","category_nicename":"obituaries","category_parent":0},{"term_id":33319,"name":"Times Record","slug":"times-record","term_group":0,"term_taxonomy_id":33547,"taxonomy":"category","description":"","parent":0,"count":123287,"filter":"raw","cat_ID":33319,"category_count":123287,"category_description":"","cat_name":"Times Record","category_nicename":"times-record","category_parent":0},{"term_id":34119,"name":"Times Record Obituaries","slug":"times-record-obituaries","term_group":0,"term_taxonomy_id":34347,"taxonomy":"category","description":"","parent":33319,"count":7904,"filter":"raw","cat_ID":34119,"category_count":7904,"category_description":"","cat_name":"Times Record Obituaries","category_nicename":"times-record-obituaries","category_parent":33319}],"ignored_categories":["33339","33343","33335","33347","21496","24110","24342","25272","26108","26112","26360","26420","26456","26472","25276","25288","415","34115","33323","33327"],"special_categories":["33319"],"should_ignore":"1","category_paywall":"33319","absence_after":"15","absence_gift":"0","age":"0","age_hours":"5","hardURL":"https:\/\/dev.mainetodaymedia.com\/devtools\/2021-paywall\/archive0321-pph.html","premiumURL":"https:\/\/dev.mainetodaymedia.com\/devtools\/2021-paywall\/hard0421-inline-pph.html","hardPaywallAfter":"200000","alternatePaywallCount":"10","alternatePaywallURL":"\/\/dev.mainetodaymedia.com\/devtools\/2021-paywall\/normal0621-pph.html","registeredPaywallURL":"https:\/\/dev.mainetodaymedia.com\/devtools\/2020-paywall\/registration\/registration8day-pph.html","paywallLoginURL":"\/\/myaccount.pressherald.com\/login\/universal\/","cookieViewCountLength":"30","ipStackTowns":[],"ipStackURLs":[],"ipStackEndpoint":"https:\/\/api.ipstack.com\/check?access_key=05844a59daaff69dfbf42b0d3aa4fb13","isActive":"false"};
/* ]]> */
</script>
<script type="text/javascript" src="https://cdnjs.cloudflare.com/ajax/libs/handlebars.js/4.0.10/handlebars.min.js?ver=5.9.3" async id="handlebars-js"></script>
<script type='text/javascript' id='mtm-gpt-script-header-js-extra'>
/* <![CDATA[ */
var mtmads = {"dfpId":"6119","ad_tags":{"pos_1_atf_728x90":{"url_vars":{"pos":"1","size":"320, 50","size_mapping":"pos1","min_width":false,"class":"mtm-leaderboard-pos1"},"disabled_assets":["video"],"device":["desktop","mobile"],"location":["home","news","business","opinion","obituaries","obits","sports","life","auto","realestate","jobs","article","weather","things-to-do","out-and-about","forecaster","times-record"]},"pos_MR_185x90":{"url_vars":{"pos":"mr","size":"185, 90","size_mapping":"marqears","min_width":false,"class":"pos_MR_185x90"},"disabled_assets":["video"],"device":["desktop"],"location":["home","times-record"]},"pos_ML_185x90":{"url_vars":{"pos":"ml","size":"185, 90","size_mapping":"marqears","min_width":false,"class":"pos_ML_185x90"},"disabled_assets":["video"],"device":["desktop"],"location":["home","times-record"]},"pos_2_atf_300x250":{"url_vars":{"pos":"2","fold":"","size":"300,250","size_mapping":"pos2","min_width":false,"class":"pos_2_atf_300x250"},"disabled_assets":["video"],"device":["desktop","mobile"],"location":["home","news","business","opinion","obituaries","obits","sports","life","auto","realestate","jobs","article","things-to-do","out-and-about","forecaster","times-record","weather"]},"pos_3_btf_300x250_300x600":{"url_vars":{"pos":"3","fold":"","size":"300,250","size_mapping":"pos3","min_width":false},"disabled_assets":["video"],"device":["desktop","mobile"],"location":["home","news","business","opinion","obituaries","obits","sports","life","auto","realestate","jobs","article","things-to-do","out-and-about","forecaster","times-record","weather"]},"pos_btf_8_300x250":{"url_vars":{"pos":"8","size":"300,250","size_mapping":"btfmr","min_width":"767"},"disabled_assets":["video"],"device":["desktop"],"location":["home","news","business","opinion","sports","life","obituaries","obits","auto","realestate","article","weather","things-to-do","out-and-about","forecaster","times-record"]},"native_ad":{"url_vars":{"pos":"native","size":"'fluid'","size_mapping":false},"disabled_assets":["video"],"device":["desktop","mobile"],"location":["news","business","opinion","sports","life","article","things-to-do","out-and-about","forecaster","times-record"]},"spotlight":{"url_vars":{"pos":"spotlight","size":"'fluid'","size_mapping":false},"disabled_assets":["video"],"device":["desktop"],"location":["home","times-record"]},"pos_f_320x50":{"url_vars":{"pos":"f","size":"300,50","size_mapping":"footer","min_width":"0"},"disabled_assets":["video"],"device":["mobile"],"location":["home","news","business","opinion","sports","obituaries","obits","life","auto","realestate","article","weather","things-to-do","out-and-about","forecaster","times-record"]}},"openx_id":"541144821","adInjection":"post","disableAdInjection":"1","postCategories":["obituaries","times-record","times-record-obituaries"],"pageType":"Article","rewardedVideoSlot":"\/6119\/MaineToday_RewardedVideo"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.pressherald.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery/jquery-1.12.4-wp.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<script type="text/javascript" src="https://www.pressherald.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery-migrate/jquery-migrate-1.4.1-wp.js?ver=1.4.1-wp" async id="jquery-migrate-js"></script>
<script type='text/javascript' src='https://www.pressherald.com/wp-content/plugins/mtm-smugmug-buy-now/assets/js/mtm-smugmug-link.js?ver=1646825190' id='smugmugButtonJS-js'></script>
<script type='text/javascript' src='https://securepubads.g.doubleclick.net/tag/js/gpt.js?ver=5.9.3' async='async' id='google-publisher-tag-js'></script>
<link rel="https://api.w.org/" href="https://www.pressherald.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.pressherald.com/wp-json/wp/v2/posts/6529775" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.pressherald.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.pressherald.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 5.9.3" />
<link rel='shortlink' href='https://www.pressherald.com/?p=6529775' />
<link rel="alternate" type="application/json+oembed" href="https://www.pressherald.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.pressherald.com%2F2022%2F04%2F21%2Fobituarywilliam-e-alexander-jr%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.pressherald.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.pressherald.com%2F2022%2F04%2F21%2Fobituarywilliam-e-alexander-jr%2F&#038;format=xml" />
<script type="text/javascript">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</script><script type="text/javascript">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</script><script type="text/javascript">AdSection = 'pressherald.com/times-record/obits';
googletag.cmd.push(function() {

mtmads.pos_1_atf_728x90 = googletag.defineSlot("/6119/pressherald.com/times-record/obits", [320, 50], "pos_1_atf_728x90").setTargeting("pos", "1").defineSizeMapping(mtmads.sizeMapping.pos1).addService(googletag.pubads());

mtmads.pos_MR_185x90 = googletag.defineSlot("/6119/pressherald.com/times-record/obits", [185, 90], "pos_MR_185x90").setTargeting("pos", "mr").defineSizeMapping(mtmads.sizeMapping.marqears).addService(googletag.pubads());

mtmads.pos_ML_185x90 = googletag.defineSlot("/6119/pressherald.com/times-record/obits", [185, 90], "pos_ML_185x90").setTargeting("pos", "ml").defineSizeMapping(mtmads.sizeMapping.marqears).addService(googletag.pubads());

mtmads.pos_2_atf_300x250 = googletag.defineSlot("/6119/pressherald.com/times-record/obits", [300,250], "pos_2_atf_300x250").setTargeting("pos", "2").defineSizeMapping(mtmads.sizeMapping.pos2).addService(googletag.pubads());

mtmads.pos_3_btf_300x250_300x600 = googletag.defineSlot("/6119/pressherald.com/times-record/obits", [300,250], "pos_3_btf_300x250_300x600").setTargeting("pos", "3").defineSizeMapping(mtmads.sizeMapping.pos3).addService(googletag.pubads());

if ( viewportwidth > 767 ) {
mtmads.pos_btf_8_300x250 = googletag.defineSlot("/6119/pressherald.com/times-record/obits", [300,250], "pos_btf_8_300x250").setTargeting("pos", "8").defineSizeMapping(mtmads.sizeMapping.btfmr).addService(googletag.pubads());
}

mtmads.native_ad = googletag.defineSlot("/6119/pressherald.com/times-record/obits", ['fluid'], "native_ad").setTargeting("pos", "native").addService(googletag.pubads());

mtmads.spotlight = googletag.defineSlot("/6119/pressherald.com/times-record/obits", ['fluid'], "spotlight").setTargeting("pos", "spotlight").addService(googletag.pubads());

mtmads.pos_f_320x50 = googletag.defineSlot("/6119/pressherald.com/times-record/obits", [300,50], "pos_f_320x50").setTargeting("pos", "f").defineSizeMapping(mtmads.sizeMapping.footer).addService(googletag.pubads());
});</script>


<script>

	window.addEventListener('DOMContentLoaded', function(){
		var viewCountReg = new RegExp('mspan_paywall_views=([0-9]+)','i');
		window.dataLayer = window.dataLayer || [];
		  window.dataLayer.push( {
			 'event': 'datalayer-loaded',
			 'companyName' : 'Maine Today',
			  'categoryArray': 'obituaries,times-record,times-record-obituaries',
			  'tagArray': 'N/A',
			  'loggedIn':   (document.cookie.match(/auth0_sub/i) ? 'logged in' : 'logged out'),
			 
				'pagesToPaywall': undefined !== window.MSPAN ? window.MSPAN.Paywall.totalViews() : -1,
				'paywall_hit_count': (viewCountReg.test(document.cookie) ? document.cookie.match( viewCountReg )[1] : '0'),
				'paywall_status': /auth0_sub/.test(document.cookie) ? 'logged in' : 'logged out',
				'paywalled': adPaywallFlag(),
				'metered': isPaywalled(),
				'meterType': paywallPageStatus(),
				'premium': (paywall.premium === "0"),

			 'orientation': window.innerHeight > window.innerWidth ? 'Portrait' : 'Landscape',
			  'contentType': 'Article',
			  'verifiedAds': (typeof VerifiedAds === 'string' ? true : false),
		      'adUnit': 'pressherald.com/times-record/obits',
		      'articleID':  6529775,
		      'articlePublishTime': '2022-04-21T05:01:01Z',
		      'articleSource':'isLocal',
			   'articleType': 	'null',
				'articleUpdateTime':  '2022-04-21T05:01:01Z',
				'hierarchy': 'times-record|times-record-obituaries',
				'publicationName': 'Press Herald',
				'uid': MSPANcookieAccount(),
				'wordCount':wordCount(),
                'characterCount': charCount(),
                'paragraphCount': paragraphCount(),

		  });
	});

</script>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
			new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
			j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
			'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
		})(window,document,'script','dataLayer','GTM-TZKX8X');</script>


<meta property="fb:pages" content="" />


<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/fonts/lusitana-v6-latin-700.woff" as="font" type="font/woff" crossorigin="anonymous">
<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/fonts/lusitana-v6-latin-700.woff2" as="font" type="font/woff2" crossorigin="anonymous">
<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/fonts/lusitana-v6-latin-regular.woff" as="font" type="font/woff" crossorigin="anonymous">
<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/fonts/lusitana-v6-latin-regular.woff2" as="font" type="font/woff2" crossorigin="anonymous">
<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/fonts/open-sans-v16-latin-300.woff" as="font" type="font/woff" crossorigin="anonymous">
<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/fonts/open-sans-v16-latin-300.woff2" as="font" type="font/woff2" crossorigin="anonymous">
<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/fonts/open-sans-v16-latin-600.woff" as="font" type="font/woff" crossorigin="anonymous">
<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/fonts/open-sans-v16-latin-600.woff2" as="font" type="font/woff2" crossorigin="anonymous">
<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/fonts/open-sans-v16-latin-700.woff" as="font" type="font/woff" crossorigin="anonymous">
<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/fonts/open-sans-v16-latin-700.woff2" as="font" type="font/woff2" crossorigin="anonymous">
<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/fonts/open-sans-v16-latin-800.woff" as="font" type="font/woff" crossorigin="anonymous">
<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/fonts/open-sans-v16-latin-800.woff2" as="font" type="font/woff2" crossorigin="anonymous">
<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/fonts/open-sans-v16-latin-regular.woff" as="font" type="font/woff" crossorigin="anonymous">
<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/fonts/open-sans-v16-latin-regular.woff2" as="font" type="font/woff2" crossorigin="anonymous">
<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/fonts/oswald-v23-latin-200.woff" as="font" type="font/woff" crossorigin="anonymous">
<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/fonts/oswald-v23-latin-200.woff2" as="font" type="font/woff2" crossorigin="anonymous">
<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/fonts/oswald-v23-latin-300.woff" as="font" type="font/woff" crossorigin="anonymous">
<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/fonts/oswald-v23-latin-300.woff2" as="font" type="font/woff2" crossorigin="anonymous">
<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/fonts/oswald-v23-latin-500.woff" as="font" type="font/woff" crossorigin="anonymous">
<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/fonts/oswald-v23-latin-500.woff2" as="font" type="font/woff2" crossorigin="anonymous">
<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/fonts/oswald-v23-latin-600.woff" as="font" type="font/woff" crossorigin="anonymous">
<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/fonts/oswald-v23-latin-600.woff2" as="font" type="font/woff2" crossorigin="anonymous">
<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/fonts/oswald-v23-latin-700.woff" as="font" type="font/woff" crossorigin="anonymous">
<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/fonts/oswald-v23-latin-700.woff2" as="font" type="font/woff2" crossorigin="anonymous">
<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/fonts/oswald-v23-latin-regular.woff" as="font" type="font/woff" crossorigin="anonymous">
<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/fonts/oswald-v23-latin-regular.woff2" as="font" type="font/woff2" crossorigin="anonymous">
<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/fonts/source-sans-pro-v12-latin-regular.woff" as="font" type="font/woff" crossorigin="anonymous">
<link rel="preload" href="https://www.pressherald.com/wp-content/themes/mainetoday/assets/fonts/source-sans-pro-v12-latin-regular.woff2" as="font" type="font/woff2" crossorigin="anonymous">


<script type="text/javascript" src="https://a.omappapi.com/app/js/api.min.js" data-account="120834" data-user="109041" async></script>


<link href="https://trinitymedia.ai" rel="preconnect" crossorigin="anonymous" />
<link href="https://vd.trinitymedia.ai" rel="preconnect" crossorigin="anonymous" />

<meta name="onesignal" content="wordpress-plugin" />
<script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
                      OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
                      OneSignal.SERVICE_WORKER_PARAM = { scope: "/" };
        OneSignal.setDefaultNotificationUrl("https://www.pressherald.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = 'ece22fe9-079c-4d14-8745-a3d5b003a8e0';
oneSignal_options['allowLocalhostAsSecureOrigin'] = true;
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['title'] = "Press Herald";
oneSignal_options['welcomeNotification']['message'] = "";
oneSignal_options['path'] = "https://www.pressherald.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.47d572d6-ef9d-4d9d-8962-815db43f4beb";
oneSignal_options['promptOptions'] = { };
oneSignal_options['notifyButton'] = { };
oneSignal_options['notifyButton']['enable'] = true;
oneSignal_options['notifyButton']['position'] = 'bottom-left';
oneSignal_options['notifyButton']['theme'] = 'default';
oneSignal_options['notifyButton']['size'] = 'small';
oneSignal_options['notifyButton']['showCredit'] = false;
oneSignal_options['notifyButton']['text'] = {};
                OneSignal.init(window._oneSignalInitOptions);
                      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<script async src='/cdn-cgi/challenge-platform/h/b/scripts/invisible.js?ts=1650520800'></script></head>
<body class="post-template-default single single-post postid-6529775 single-format-standard active-paywall story-head obituaries times-record times-record-obituaries">
<div id="fb-root"></div>
<script async defer crossorigin="anonymous" src="https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v6.0&appId=178078215650057&autoLogAppEvents=1"></script>

<script type="text/javascript">
	/*
  var TriggerPrompt = function(articleUrl, contentId) {
    var ARTICLE_URL = articleUrl;
    var CONTENT_ID = contentId || '';
    var el = document.createElement('script');
 var url = 'https://survey.g.doubleclick.net/survey?site=6c5hn2ytoctdofbiyzz2q4xm3e' +
              '&url=' + encodeURIComponent(ARTICLE_URL) +
              (CONTENT_ID ? '&cid=' + encodeURIComponent(CONTENT_ID) : '') +
              '&random=' + (new Date).getTime() +
              '&after=1';
    el.setAttribute('src', url);
    var head = document.getElementsByTagName('head')[0] ||
        document.getElementsByTagName('body')[0];
    head.appendChild(el);
  };
  */
</script>

<div class="paywall-banner">
<p>
<img src="https://www.pressherald.com/wp-content/themes/mainetoday/assets/images/pph-icon.png" style="vertical-align:middle;">
<span></span>
<span>
<a href="https://www.pressherald.com/login">Sign in</a> or <a href="https://myaccount.pressherald.com/order/?ref=paywall-stub">Subscribe</a> </span>
<span class="expand-extra-messaging extra-closed">See Offers</span>
<span class="close-slidedown">
<img src="https://www.pressherald.com/wp-content/themes/mainetoday/assets/images/close-icon.png" style="vertical-align:middle;">
</span>
</p>
<div class="special-messaging">
<p></p>
<img src="" />
<br>
</div>
</div>
<div class="js-login-container">
<div id="paywall-login-form">
<div class="login-close"><i class='fa fa-close'></i></div>
<h3>Sign In:</h3>
<form id="paywall-modal-login" method="post" action="https://myaccount.pressherald.com/login/">
<div class="message"></div>
<input type="text" name="email" placeholder="Email"><br />
<input type="password" name="password" placeholder="Password">
<div class="fa-3x">
<i class="fas fa-circle-notch fa-spin"></i>
</div>
<button type="submit">Login</button>
<div class="login-sm-text"><a href="https://www.pressherald.com/forgot-password">Forgot password?</a> &nbsp;&nbsp;| &nbsp;&nbsp;<a href=" https://www.pressherald.com/subscribe">Subscribe now</a></div>
</form>
</div>
</div>

<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-TZKX8X"
					  height="0" width="0" style="display:none;visibility:hidden"></iframe>
	</noscript>


<div class="mtm-utility-launch">
<div class="search-mobile slide">
<form method="get" action="https://www.pressherald.com/" id="searchform" class="search-mobile-form">
<input type="text" class="search-box" name="s" id="s" placeholder="What are you looking for?" onFocus="this.placeholder = ''" onBlur="this.placeholder = 'Looking for something?'">
<input type="submit" value="" class="search-submit-off" id="searchsubmit">
</form>
</div>

<div class="utility-menu-skin">
<ul id="utility-menu" class="menu"><li id="menu-item-1201403" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1201403 depth-0"><a href="https://www.pressherald.com/news/">News</a>
<ul class="sub-menu">
<li id="menu-item-2332344" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2332344 depth-1"><a href="https://www.pressherald.com/news/">All News</a></li>
<li id="menu-item-3334311" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3334311 depth-1"><a href="https://www.pressherald.com/times-record/">Times Record</a></li>
<li id="menu-item-3065108" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3065108 depth-1"><a href="https://www.pressherald.com/forecaster/">The Forecaster</a></li>
<li id="menu-item-3065112" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3065112 depth-1"><a href="https://www.pressherald.com/american-journal/">American Journal</a></li>
<li id="menu-item-3065116" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3065116 depth-1"><a href="https://www.pressherald.com/lakes-region-weekly/">Lakes Region Weekly</a></li>
<li id="menu-item-3355607" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3355607 depth-1"><a href="https://www.pressherald.com/mainely-media/">Mainely Media Weeklies</a></li>
<li id="menu-item-1201405" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201405 depth-1"><a href="https://www.pressherald.com/news/localstate/">Local &amp; State</a></li>
<li id="menu-item-1201406" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201406 depth-1"><a href="https://www.pressherald.com/news/mainecrime/">Cops &amp; Courts</a></li>
<li id="menu-item-1245743" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1245743 depth-1"><a href="https://www.pressherald.com/news/new-england/">New England</a></li>
<li id="menu-item-1201407" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201407 depth-1"><a href="https://www.pressherald.com/politics/">Politics</a></li>
<li id="menu-item-1201404" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201404 depth-1"><a href="https://www.pressherald.com/news/nationworld/">Nation &amp; World</a></li>
<li id="menu-item-1332624" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1332624 depth-1"><a href="https://www.pressherald.com/news/healthcare/">Health care</a></li>
<li id="menu-item-1214176" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1214176 depth-1"><a href="https://www.pressherald.com/news/schools/">Schools</a></li>
<li id="menu-item-1201408" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1201408 depth-1"><a href="http://pressherald.com/lost">Lost: Maine&#8217;s Opioid Crisis</a></li>
<li id="menu-item-3069488" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3069488 depth-1"><a href="https://www.pressherald.com/scene-heard/">Society Notebook</a></li>
</ul>
</li>
<li id="menu-item-1201410" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1201410 depth-0"><a href="https://www.pressherald.com/sports/">Sports</a>
<ul class="sub-menu">
<li id="menu-item-1201517" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1201517 depth-1"><a href="https://www.pressherald.com/sports/">All Sports</a></li>
<li id="menu-item-1201518" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1201518 depth-1"><a href="https://www.pressherald.com/sports/highschoolsports/">Varsity Maine</a></li>
<li id="menu-item-6281268" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6281268 depth-1"><a href="https://masthead.smugmug.com/">Purchase Photos</a></li>
<li id="menu-item-1201417" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201417 depth-1"><a href="https://www.pressherald.com/sports/outdoors/">Outdoors</a></li>
<li id="menu-item-2333060" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2333060 depth-1"><a href="https://www.pressherald.com/sports/college/">Colleges</a></li>
<li id="menu-item-2333172" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2333172 depth-1"><a href="https://www.pressherald.com/sports/seadogs/">Portland Sea Dogs</a></li>
<li id="menu-item-1201418" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201418 depth-1"><a href="https://www.pressherald.com/sports/redsox/">Boston Red Sox</a></li>
<li id="menu-item-1201415" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201415 depth-1"><a href="https://www.pressherald.com/sports/patriots/">New England Patriots</a></li>
</ul>
</li>
<li id="menu-item-1201419" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1201419 depth-0"><a href="https://www.pressherald.com/opinion/">Opinion</a>
<ul class="sub-menu">
<li id="menu-item-1201525" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1201525 depth-1"><a href="https://www.pressherald.com/opinion/">All Opinion</a></li>
<li id="menu-item-1703094" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1703094 depth-1"><a href="https://www.pressherald.com/opinion/meetinghouse/">Meetinghouse</a></li>
<li id="menu-item-1201420" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201420 depth-1"><a href="https://www.pressherald.com/opinion/editorials/">Editorials</a></li>
<li id="menu-item-1201421" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201421 depth-1"><a href="https://www.pressherald.com/letters/">Letters</a></li>
<li id="menu-item-1201422" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201422 depth-1"><a href="https://www.pressherald.com/opinion/bill-nemitz-opinion/">Bill Nemitz</a></li>
<li id="menu-item-1201423" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201423 depth-1"><a href="https://www.pressherald.com/opinion/greg-kesich-opinion/">Greg Kesich</a></li>
</ul>
</li>
<li id="menu-item-1201424" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1201424 depth-0"><a href="https://www.pressherald.com/business/">Business</a>
<ul class="sub-menu">
<li id="menu-item-1201524" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1201524 depth-1"><a href="https://www.pressherald.com/business/">All Business</a></li>
<li id="menu-item-1294746" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1294746 depth-1"><a href="https://www.pressherald.com/business/cannabis-report/">Maine Cannabis Report</a></li>
<li id="menu-item-1201425" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201425 depth-1"><a href="https://www.pressherald.com/business/people-on-the-move/">People on the Move</a></li>
<li id="menu-item-5933787" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5933787 depth-1"><a href="https://www.pressherald.com/policymatters/">Policy Matters Events</a></li>
<li id="menu-item-5441306" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5441306 depth-1"><a href="https://www.pressherald.com/news/events/like-a-boss/">Like A Boss Events</a></li>
<li id="menu-item-5395774" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5395774 depth-1"><a href="https://www.pressherald.com/business-series/">Making It Work Events</a></li>
</ul>
</li>
<li id="menu-item-2333808" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2333808 depth-0"><a href="https://www.pressherald.com/life/audience/">A&amp;E</a>
<ul class="sub-menu">
<li id="menu-item-3127103" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3127103 depth-1"><a href="https://www.pressherald.com/life/arts-entertainment/">All A&amp;E</a></li>
<li id="menu-item-2334032" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2334032 depth-1"><a href="https://www.pressherald.com/life/books/">Books</a></li>
<li id="menu-item-1201438" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1201438 depth-1"><a href="https://www.pressherald.com/sudoku/">Sudoku</a></li>
<li id="menu-item-1201437" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1201437 depth-1"><a href="https://www.pressherald.com/crossword/">Crossword</a></li>
</ul>
</li>
<li id="menu-item-1201427" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1201427 depth-0"><a href="https://www.pressherald.com/foodanddining/">Food</a>
<ul class="sub-menu">
<li id="menu-item-2334996" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2334996 depth-1"><a href="https://www.pressherald.com/foodanddining/">All Food</a></li>
<li id="menu-item-2335020" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2335020 depth-1"><a href="https://www.pressherald.com/foodanddining/restaurant-reviews/">Restaurant reviews</a></li>
<li id="menu-item-2335016" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2335016 depth-1"><a href="https://www.pressherald.com/foodanddining/cookbook-reviews/">Cookbook Reviews</a></li>
<li id="menu-item-2335036" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2335036 depth-1"><a href="https://www.pressherald.com/foodanddining/recipes/">Recipes</a></li>
<li id="menu-item-2335044" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2335044 depth-1"><a href="https://www.pressherald.com/foodanddining/vegan-kitchen/">Vegan Kitchen</a></li>
<li id="menu-item-3105185" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3105185 depth-1"><a href="https://www.pressherald.com/source/green-plate-special/">Green Plate Special</a></li>
<li id="menu-item-3105181" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3105181 depth-1"><a href="https://www.pressherald.com/source/maine-gardener/">Maine Gardener</a></li>
</ul>
</li>
<li id="menu-item-2334052" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-2334052 depth-0"><a href="https://www.pressherald.com/things-to-do/">Do This</a>
<ul class="sub-menu">
<li id="menu-item-2334476" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2334476 depth-1"><a href="https://www.pressherald.com/things-to-do/">All Do This</a></li>
<li id="menu-item-3172855" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3172855 depth-1"><a href="https://www.pressherald.com/things-to-do/guides/">Guides</a></li>
<li id="menu-item-5441310" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5441310 depth-1"><a href="https://www.pressherald.com/news/events/maine-voices-live/">Maine Voices Live Events</a></li>
<li id="menu-item-5441314" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5441314 depth-1"><a href="https://www.pressherald.com/news/events/like-a-boss/">Like A Boss Events</a></li>
<li id="menu-item-5441302" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5441302 depth-1"><a href="https://www.pressherald.com/business-series/">Making It Work Events</a></li>
<li id="menu-item-1628550" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1628550 depth-1"><a href="https://www.pressherald.com/things-to-do/do-this-calendar/#!/">Event Calendar</a></li>
</ul>
</li>
<li id="menu-item-1201430" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1201430 depth-0"><a href="/obituaries">Obits</a></li>
<li id="menu-item-1201431" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1201431 depth-0"><a href="#">Classifieds</a>
<ul class="sub-menu">
<li id="menu-item-1535634" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1535634 depth-1"><a href="https://mainejobs.com">Jobs</a></li>
<li id="menu-item-1201432" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201432 depth-1"><a href="https://www.pressherald.com/realestate/">Real Estate</a></li>
<li id="menu-item-1201433" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201433 depth-1"><a href="https://www.pressherald.com/auto/">Auto</a></li>
</ul>
</li>
<li id="menu-item-1201435" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1201435 depth-0"><a href="http://www.mainenotices.com/?utm_source=pressherald.com&#038;utm_medium=referral&#038;utm_campaign=menu">Public Notices</a></li>
<li id="menu-item-1201523" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1201523 depth-0"><a href="https://www.pressherald.com/signature-events/">Events</a></li>
<li id="menu-item-6416132" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6416132 depth-0"><a href="https://www.pressherald.com/epaper/">ePapers</a></li>
<li id="menu-item-6416138" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6416138 depth-0"><a href="https://www.pressherald.com/newsletters/">Newsletters and alerts</a></li>
<li id="menu-item-6416240" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6416240 depth-0"><a href="https://www.pressherald.com/mobile-products/">Mobile Apps</a></li>
<li id="menu-item-6416180" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-6416180 depth-0"><a href="#">Network</a>
<ul class="sub-menu">
<li id="menu-item-5941791" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5941791 depth-1"><a href="https://www.pressherald.com/times-record/">Timesrecord.com</a></li>
<li id="menu-item-1201488" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1201488 depth-1"><a href="http://centralmaine.com">Centralmaine.com</a></li>
<li id="menu-item-2338544" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2338544 depth-1"><a href="https://www.sunjournal.com/">Sunjournal.com</a></li>
<li id="menu-item-6416183" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6416183 depth-1"><a href="https://www.pressherald.com/sports/highschoolsports/">Varsity Maine</a></li>
<li id="menu-item-6416186" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6416186 depth-1"><a href="https://www.pressherald.com/forecaster/">The Forecaster</a></li>
<li id="menu-item-6416189" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6416189 depth-1"><a href="https://www.pressherald.com/mainely-media/">Mainely Media</a></li>
</ul>
</li>
<li id="menu-item-6416108" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6416108 depth-0"><a href="https://store.masthead.me">Merch Store</a></li>
<li id="menu-item-6236625" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6236625 depth-0"><a href="https://photos.masthead.me">Photo Store</a></li>
<li id="menu-item-1323997" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1323997 depth-0"><a href="https://www.pressherald.com/career-opportunities/">Work Here</a></li>
<li id="menu-item-1201500" class="subscribe-nav menu-item menu-item-type-post_type menu-item-object-page menu-item-1201500 depth-0"><a href="https://www.pressherald.com/contact-advertising/">Advertise</a></li>
<li id="menu-item-6416153" class="subscribe-nav menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-6416153 depth-0"><a href="#">Subscribe</a>
<ul class="sub-menu">
<li id="menu-item-6416615" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6416615 depth-1"><a href="https://www.pressherald.com/subscribe">Press Herald Subscription</a></li>
<li id="menu-item-6416207" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6416207 depth-1"><a href="https://www.pressherald.com/gift">Press Herald Gift</a></li>
<li id="menu-item-6416159" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6416159 depth-1"><a href="https://subscribe.timesrecord.com">Times Record Subscription</a></li>
<li id="menu-item-6416231" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6416231 depth-1"><a href="https://www.timesrecord.com/gift">Times Record Gift</a></li>
</ul>
</li>
<li id="menu-item-1201493" class="myaccount-nav menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1201493 depth-0"><a href="#">Account Management</a>
<ul class="sub-menu">
<li id="menu-item-6416114" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6416114 depth-1"><a href="https://myaccount.pressherald.com">Manage Press Herald Account</a></li>
<li id="menu-item-6416123" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6416123 depth-1"><a href="https://myaccount.pressherald.com/mtm_pt/complaint">Press Herald Delivery Issues</a></li>
<li id="menu-item-6416120" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6416120 depth-1"><a href="https://myaccount.timesrecord.com">Manage Times Record Account</a></li>
<li id="menu-item-6416126" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6416126 depth-1"><a href="https://myaccount.timesrecord.com/amg_tr/complaint">Times Record Delivery Issues</a></li>
<li id="menu-item-6416129" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6416129 depth-1"><a href="https://www.pressherald.com/benefits/">Subscriber benefits</a></li>
<li id="menu-item-1201496" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1201496 depth-1"><a href="https://www.pressherald.com/faqs/">FAQs</a></li>
</ul>
</li>
</ul>
</div>
<div class="utility-menu-skin-cover">
</div>
</div>
<div class="mtm-wrapper  post-wrapper ">
<div class="mtm-header story-head">

<div class="search-mobile slide">
<form method="get" action="https://www.pressherald.com/" id="searchform" class="search-mobile-form">
<input type="text" class="search-box" name="s" id="s" placeholder="What are you looking for?" onFocus="this.placeholder = ''" onBlur="this.placeholder = 'Looking for something?'">
<input type="submit" value="" class="search-submit-off" id="searchsubmit">
</form>
</div>

<div class="mobile-menu-skin">
<ul id="utility-menu" class="menu"><li id="menu-item-1201403" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1201403 depth-0"><a href="https://www.pressherald.com/news/">News</a>
<ul class="sub-menu">
<li id="menu-item-2332344" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2332344 depth-1"><a href="https://www.pressherald.com/news/">All News</a></li>
<li id="menu-item-3334311" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3334311 depth-1"><a href="https://www.pressherald.com/times-record/">Times Record</a></li>
<li id="menu-item-3065108" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3065108 depth-1"><a href="https://www.pressherald.com/forecaster/">The Forecaster</a></li>
<li id="menu-item-3065112" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3065112 depth-1"><a href="https://www.pressherald.com/american-journal/">American Journal</a></li>
<li id="menu-item-3065116" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3065116 depth-1"><a href="https://www.pressherald.com/lakes-region-weekly/">Lakes Region Weekly</a></li>
<li id="menu-item-3355607" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3355607 depth-1"><a href="https://www.pressherald.com/mainely-media/">Mainely Media Weeklies</a></li>
<li id="menu-item-1201405" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201405 depth-1"><a href="https://www.pressherald.com/news/localstate/">Local &amp; State</a></li>
<li id="menu-item-1201406" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201406 depth-1"><a href="https://www.pressherald.com/news/mainecrime/">Cops &amp; Courts</a></li>
<li id="menu-item-1245743" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1245743 depth-1"><a href="https://www.pressherald.com/news/new-england/">New England</a></li>
<li id="menu-item-1201407" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201407 depth-1"><a href="https://www.pressherald.com/politics/">Politics</a></li>
<li id="menu-item-1201404" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201404 depth-1"><a href="https://www.pressherald.com/news/nationworld/">Nation &amp; World</a></li>
<li id="menu-item-1332624" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1332624 depth-1"><a href="https://www.pressherald.com/news/healthcare/">Health care</a></li>
<li id="menu-item-1214176" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1214176 depth-1"><a href="https://www.pressherald.com/news/schools/">Schools</a></li>
<li id="menu-item-1201408" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1201408 depth-1"><a href="http://pressherald.com/lost">Lost: Maine&#8217;s Opioid Crisis</a></li>
<li id="menu-item-3069488" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3069488 depth-1"><a href="https://www.pressherald.com/scene-heard/">Society Notebook</a></li>
</ul>
</li>
<li id="menu-item-1201410" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1201410 depth-0"><a href="https://www.pressherald.com/sports/">Sports</a>
<ul class="sub-menu">
<li id="menu-item-1201517" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1201517 depth-1"><a href="https://www.pressherald.com/sports/">All Sports</a></li>
<li id="menu-item-1201518" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1201518 depth-1"><a href="https://www.pressherald.com/sports/highschoolsports/">Varsity Maine</a></li>
<li id="menu-item-6281268" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6281268 depth-1"><a href="https://masthead.smugmug.com/">Purchase Photos</a></li>
<li id="menu-item-1201417" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201417 depth-1"><a href="https://www.pressherald.com/sports/outdoors/">Outdoors</a></li>
<li id="menu-item-2333060" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2333060 depth-1"><a href="https://www.pressherald.com/sports/college/">Colleges</a></li>
<li id="menu-item-2333172" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2333172 depth-1"><a href="https://www.pressherald.com/sports/seadogs/">Portland Sea Dogs</a></li>
<li id="menu-item-1201418" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201418 depth-1"><a href="https://www.pressherald.com/sports/redsox/">Boston Red Sox</a></li>
<li id="menu-item-1201415" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201415 depth-1"><a href="https://www.pressherald.com/sports/patriots/">New England Patriots</a></li>
</ul>
</li>
<li id="menu-item-1201419" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1201419 depth-0"><a href="https://www.pressherald.com/opinion/">Opinion</a>
<ul class="sub-menu">
<li id="menu-item-1201525" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1201525 depth-1"><a href="https://www.pressherald.com/opinion/">All Opinion</a></li>
<li id="menu-item-1703094" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1703094 depth-1"><a href="https://www.pressherald.com/opinion/meetinghouse/">Meetinghouse</a></li>
<li id="menu-item-1201420" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201420 depth-1"><a href="https://www.pressherald.com/opinion/editorials/">Editorials</a></li>
<li id="menu-item-1201421" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201421 depth-1"><a href="https://www.pressherald.com/letters/">Letters</a></li>
<li id="menu-item-1201422" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201422 depth-1"><a href="https://www.pressherald.com/opinion/bill-nemitz-opinion/">Bill Nemitz</a></li>
<li id="menu-item-1201423" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201423 depth-1"><a href="https://www.pressherald.com/opinion/greg-kesich-opinion/">Greg Kesich</a></li>
</ul>
</li>
<li id="menu-item-1201424" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1201424 depth-0"><a href="https://www.pressherald.com/business/">Business</a>
<ul class="sub-menu">
<li id="menu-item-1201524" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1201524 depth-1"><a href="https://www.pressherald.com/business/">All Business</a></li>
<li id="menu-item-1294746" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1294746 depth-1"><a href="https://www.pressherald.com/business/cannabis-report/">Maine Cannabis Report</a></li>
<li id="menu-item-1201425" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201425 depth-1"><a href="https://www.pressherald.com/business/people-on-the-move/">People on the Move</a></li>
<li id="menu-item-5933787" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5933787 depth-1"><a href="https://www.pressherald.com/policymatters/">Policy Matters Events</a></li>
<li id="menu-item-5441306" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5441306 depth-1"><a href="https://www.pressherald.com/news/events/like-a-boss/">Like A Boss Events</a></li>
<li id="menu-item-5395774" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5395774 depth-1"><a href="https://www.pressherald.com/business-series/">Making It Work Events</a></li>
</ul>
</li>
<li id="menu-item-2333808" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2333808 depth-0"><a href="https://www.pressherald.com/life/audience/">A&amp;E</a>
<ul class="sub-menu">
<li id="menu-item-3127103" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3127103 depth-1"><a href="https://www.pressherald.com/life/arts-entertainment/">All A&amp;E</a></li>
<li id="menu-item-2334032" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2334032 depth-1"><a href="https://www.pressherald.com/life/books/">Books</a></li>
<li id="menu-item-1201438" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1201438 depth-1"><a href="https://www.pressherald.com/sudoku/">Sudoku</a></li>
<li id="menu-item-1201437" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1201437 depth-1"><a href="https://www.pressherald.com/crossword/">Crossword</a></li>
</ul>
</li>
<li id="menu-item-1201427" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1201427 depth-0"><a href="https://www.pressherald.com/foodanddining/">Food</a>
<ul class="sub-menu">
<li id="menu-item-2334996" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2334996 depth-1"><a href="https://www.pressherald.com/foodanddining/">All Food</a></li>
<li id="menu-item-2335020" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2335020 depth-1"><a href="https://www.pressherald.com/foodanddining/restaurant-reviews/">Restaurant reviews</a></li>
<li id="menu-item-2335016" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2335016 depth-1"><a href="https://www.pressherald.com/foodanddining/cookbook-reviews/">Cookbook Reviews</a></li>
<li id="menu-item-2335036" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2335036 depth-1"><a href="https://www.pressherald.com/foodanddining/recipes/">Recipes</a></li>
<li id="menu-item-2335044" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2335044 depth-1"><a href="https://www.pressherald.com/foodanddining/vegan-kitchen/">Vegan Kitchen</a></li>
<li id="menu-item-3105185" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3105185 depth-1"><a href="https://www.pressherald.com/source/green-plate-special/">Green Plate Special</a></li>
<li id="menu-item-3105181" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3105181 depth-1"><a href="https://www.pressherald.com/source/maine-gardener/">Maine Gardener</a></li>
</ul>
</li>
<li id="menu-item-2334052" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-2334052 depth-0"><a href="https://www.pressherald.com/things-to-do/">Do This</a>
<ul class="sub-menu">
<li id="menu-item-2334476" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2334476 depth-1"><a href="https://www.pressherald.com/things-to-do/">All Do This</a></li>
<li id="menu-item-3172855" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3172855 depth-1"><a href="https://www.pressherald.com/things-to-do/guides/">Guides</a></li>
<li id="menu-item-5441310" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5441310 depth-1"><a href="https://www.pressherald.com/news/events/maine-voices-live/">Maine Voices Live Events</a></li>
<li id="menu-item-5441314" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5441314 depth-1"><a href="https://www.pressherald.com/news/events/like-a-boss/">Like A Boss Events</a></li>
<li id="menu-item-5441302" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5441302 depth-1"><a href="https://www.pressherald.com/business-series/">Making It Work Events</a></li>
<li id="menu-item-1628550" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1628550 depth-1"><a href="https://www.pressherald.com/things-to-do/do-this-calendar/#!/">Event Calendar</a></li>
</ul>
</li>
<li id="menu-item-1201430" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1201430 depth-0"><a href="/obituaries">Obits</a></li>
<li id="menu-item-1201431" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1201431 depth-0"><a href="#">Classifieds</a>
<ul class="sub-menu">
<li id="menu-item-1535634" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1535634 depth-1"><a href="https://mainejobs.com">Jobs</a></li>
<li id="menu-item-1201432" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201432 depth-1"><a href="https://www.pressherald.com/realestate/">Real Estate</a></li>
<li id="menu-item-1201433" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201433 depth-1"><a href="https://www.pressherald.com/auto/">Auto</a></li>
</ul>
</li>
<li id="menu-item-1201435" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1201435 depth-0"><a href="http://www.mainenotices.com/?utm_source=pressherald.com&#038;utm_medium=referral&#038;utm_campaign=menu">Public Notices</a></li>
<li id="menu-item-1201523" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1201523 depth-0"><a href="https://www.pressherald.com/signature-events/">Events</a></li>
<li id="menu-item-6416132" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6416132 depth-0"><a href="https://www.pressherald.com/epaper/">ePapers</a></li>
<li id="menu-item-6416138" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6416138 depth-0"><a href="https://www.pressherald.com/newsletters/">Newsletters and alerts</a></li>
<li id="menu-item-6416240" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6416240 depth-0"><a href="https://www.pressherald.com/mobile-products/">Mobile Apps</a></li>
<li id="menu-item-6416180" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-6416180 depth-0"><a href="#">Network</a>
<ul class="sub-menu">
<li id="menu-item-5941791" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5941791 depth-1"><a href="https://www.pressherald.com/times-record/">Timesrecord.com</a></li>
<li id="menu-item-1201488" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1201488 depth-1"><a href="http://centralmaine.com">Centralmaine.com</a></li>
<li id="menu-item-2338544" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2338544 depth-1"><a href="https://www.sunjournal.com/">Sunjournal.com</a></li>
<li id="menu-item-6416183" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6416183 depth-1"><a href="https://www.pressherald.com/sports/highschoolsports/">Varsity Maine</a></li>
<li id="menu-item-6416186" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6416186 depth-1"><a href="https://www.pressherald.com/forecaster/">The Forecaster</a></li>
<li id="menu-item-6416189" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-6416189 depth-1"><a href="https://www.pressherald.com/mainely-media/">Mainely Media</a></li>
</ul>
</li>
<li id="menu-item-6416108" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6416108 depth-0"><a href="https://store.masthead.me">Merch Store</a></li>
<li id="menu-item-6236625" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6236625 depth-0"><a href="https://photos.masthead.me">Photo Store</a></li>
<li id="menu-item-1323997" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1323997 depth-0"><a href="https://www.pressherald.com/career-opportunities/">Work Here</a></li>
<li id="menu-item-1201500" class="subscribe-nav menu-item menu-item-type-post_type menu-item-object-page menu-item-1201500 depth-0"><a href="https://www.pressherald.com/contact-advertising/">Advertise</a></li>
<li id="menu-item-6416153" class="subscribe-nav menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-6416153 depth-0"><a href="#">Subscribe</a>
<ul class="sub-menu">
<li id="menu-item-6416615" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6416615 depth-1"><a href="https://www.pressherald.com/subscribe">Press Herald Subscription</a></li>
<li id="menu-item-6416207" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6416207 depth-1"><a href="https://www.pressherald.com/gift">Press Herald Gift</a></li>
<li id="menu-item-6416159" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6416159 depth-1"><a href="https://subscribe.timesrecord.com">Times Record Subscription</a></li>
<li id="menu-item-6416231" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6416231 depth-1"><a href="https://www.timesrecord.com/gift">Times Record Gift</a></li>
</ul>
</li>
<li id="menu-item-1201493" class="myaccount-nav menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-1201493 depth-0"><a href="#">Account Management</a>
<ul class="sub-menu">
<li id="menu-item-6416114" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6416114 depth-1"><a href="https://myaccount.pressherald.com">Manage Press Herald Account</a></li>
<li id="menu-item-6416123" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6416123 depth-1"><a href="https://myaccount.pressherald.com/mtm_pt/complaint">Press Herald Delivery Issues</a></li>
<li id="menu-item-6416120" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6416120 depth-1"><a href="https://myaccount.timesrecord.com">Manage Times Record Account</a></li>
<li id="menu-item-6416126" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6416126 depth-1"><a href="https://myaccount.timesrecord.com/amg_tr/complaint">Times Record Delivery Issues</a></li>
<li id="menu-item-6416129" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6416129 depth-1"><a href="https://www.pressherald.com/benefits/">Subscriber benefits</a></li>
<li id="menu-item-1201496" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1201496 depth-1"><a href="https://www.pressherald.com/faqs/">FAQs</a></li>
</ul>
</li>
</ul></div>
<div class="mobile-menu-skin-cover">
</div>
</div>
<div class="main-nav-container  fixed-top">
<div class="main-menu-togglers" style="color:#fff">
<div class="menu-expand">
<div id="nav-icon3"><span></span><span></span><span></span><span></span></div>
</div>
</div>
<div class="fixed-p-icon"><a href="/"><img src="https://www.pressherald.com/wp-content/themes/mainetoday/assets/images/pph-fixed-icon.png"></a></div>
<ul id="sub-logo-menu" class="menu"><li id="menu-item-1201355" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1201355 depth-0"><a href="https://www.pressherald.com/news/">News</a>
<ul class="sub-menu">
<li id="menu-item-2331556" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2331556 depth-1"><a href="https://www.pressherald.com/news/">All News</a></li>
<li id="menu-item-3334307" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3334307 depth-1"><a href="https://www.pressherald.com/times-record/">Times Record</a></li>
<li id="menu-item-5512734" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5512734 depth-1"><a href="https://www.pressherald.com/news/localstate/">Local &amp; State</a></li>
<li id="menu-item-3065088" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-3065088 depth-1"><a href="https://www.pressherald.com/forecaster/">The Forecaster</a></li>
<li id="menu-item-1201358" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201358 depth-1"><a href="https://www.pressherald.com/news/mainecrime/">Cops &amp; Courts</a></li>
<li id="menu-item-3065092" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3065092 depth-1"><a href="https://www.pressherald.com/american-journal/">American Journal</a></li>
<li id="menu-item-1245745" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1245745 depth-1"><a href="https://www.pressherald.com/news/new-england/">New England</a></li>
<li id="menu-item-3065096" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3065096 depth-1"><a href="https://www.pressherald.com/lakes-region-weekly/">Lakes Region Weekly</a></li>
<li id="menu-item-1548374" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1548374 depth-1"><a href="https://www.pressherald.com/politics/">Politics</a></li>
<li id="menu-item-5862308" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5862308 depth-1"><a href="https://www.pressherald.com/mainely-media/">Mainely Media Weeklies</a></li>
<li id="menu-item-1201356" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201356 depth-1"><a href="https://www.pressherald.com/news/nationworld/">Nation &amp; World</a></li>
<li id="menu-item-1332620" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1332620 depth-1"><a href="https://www.pressherald.com/news/healthcare/">Health care</a></li>
<li id="menu-item-1214174" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1214174 depth-1"><a href="https://www.pressherald.com/news/schools/">Schools</a></li>
<li id="menu-item-1201360" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201360 depth-1"><a href="https://www.pressherald.com/news/community-news/">Community News</a></li>
<li id="menu-item-3069484" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3069484 depth-1"><a href="https://www.pressherald.com/scene-heard/">Society Notebook</a></li>
<li id="menu-item-1201361" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1201361 depth-1"><a href="http://pressherald.com/lost">Lost: Maine&#8217;s Opioid Crisis</a></li>
</ul>
</li>
<li id="menu-item-1201362" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1201362 depth-0"><a href="https://www.pressherald.com/business/">Business</a>
<ul class="sub-menu">
<li id="menu-item-2331576" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2331576 depth-1"><a href="https://www.pressherald.com/business/">All Business</a></li>
<li id="menu-item-1295796" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1295796 depth-1"><a href="/business/cannabis-report">Maine Cannabis Report</a></li>
<li id="menu-item-5395726" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5395726 depth-1"><a href="https://www.pressherald.com/business-series/">Making It Work Events</a></li>
<li id="menu-item-5933784" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5933784 depth-1"><a href="https://www.pressherald.com/policymatters/">Policy Matters events</a></li>
<li id="menu-item-5443334" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5443334 depth-1"><a href="https://www.pressherald.com/news/events/like-a-boss/">Like A Boss Events</a></li>
<li id="menu-item-1201366" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201366 depth-1"><a href="https://www.pressherald.com/business/people-on-the-move/">People on the Move</a></li>
<li id="menu-item-1611226" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1611226 depth-1"><a href="https://www.pressherald.com/maine-commercial-real-estate/">Commercial Real Estate</a></li>
</ul>
</li>
<li id="menu-item-1201367" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1201367 depth-0"><a href="https://www.pressherald.com/opinion/">Opinion</a>
<ul class="sub-menu">
<li id="menu-item-2331564" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2331564 depth-1"><a href="https://www.pressherald.com/opinion/">All Opinion</a></li>
<li id="menu-item-1703098" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1703098 depth-1"><a href="https://www.pressherald.com/opinion/meetinghouse/">Meetinghouse</a></li>
<li id="menu-item-1201368" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201368 depth-1"><a href="https://www.pressherald.com/opinion/editorials/">Editorials</a></li>
<li id="menu-item-1201369" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201369 depth-1"><a href="https://www.pressherald.com/letters/">Letters</a></li>
<li id="menu-item-1201644" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201644 depth-1"><a href="https://www.pressherald.com/opinion/columnists-opinion/">Columns</a></li>
<li id="menu-item-1201370" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201370 depth-1"><a href="https://www.pressherald.com/opinion/bill-nemitz-opinion/">Bill Nemitz</a></li>
<li id="menu-item-1201371" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201371 depth-1"><a href="https://www.pressherald.com/opinion/greg-kesich-opinion/">Greg Kesich</a></li>
</ul>
</li>
<li id="menu-item-1201372" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1201372 depth-0"><a href="https://www.pressherald.com/sports/">Sports</a>
<ul class="sub-menu">
<li id="menu-item-2331588" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2331588 depth-1"><a href="https://www.pressherald.com/sports">All Sports</a></li>
<li id="menu-item-1201508" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1201508 depth-1"><a href="https://www.pressherald.com/sports/highschoolsports/">Varsity Maine</a></li>
<li id="menu-item-2331596" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2331596 depth-1"><a href="https://www.pressherald.com/sports/college/">Colleges</a></li>
<li id="menu-item-6281265" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6281265 depth-1"><a href="https://masthead.smugmug.com/">Purchase Photos</a></li>
<li id="menu-item-1201510" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201510 depth-1"><a href="https://www.pressherald.com/sports/outdoors/">Outdoors</a></li>
<li id="menu-item-2331592" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2331592 depth-1"><a href="https://www.pressherald.com/sports/seadogs/">Portland Sea Dogs</a></li>
<li id="menu-item-1201375" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201375 depth-1"><a href="https://www.pressherald.com/sports/redsox/">Boston Red Sox</a></li>
<li id="menu-item-1201376" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201376 depth-1"><a href="https://www.pressherald.com/sports/patriots/">New England Patriots</a></li>
</ul>
</li>
<li id="menu-item-2331600" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2331600 depth-0"><a href="https://www.pressherald.com/arts-entertainment/">A&amp;E</a>
<ul class="sub-menu">
<li id="menu-item-3080001" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3080001 depth-1"><a href="https://www.pressherald.com/life/arts-entertainment/">All A&amp;E</a></li>
<li id="menu-item-1201386" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201386 depth-1"><a href="https://www.pressherald.com/life/books/">Books</a></li>
<li id="menu-item-1201515" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1201515 depth-1"><a href="https://www.pressherald.com/sudoku/">Sudoku</a></li>
<li id="menu-item-1201514" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1201514 depth-1"><a href="https://www.pressherald.com/crossword/">Crossword</a></li>
</ul>
</li>
<li id="menu-item-1201382" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1201382 depth-0"><a href="https://www.pressherald.com/foodanddining/">Food</a>
<ul class="sub-menu">
<li id="menu-item-2331612" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2331612 depth-1"><a href="https://www.pressherald.com/foodanddining/">All Food</a></li>
<li id="menu-item-1201385" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1201385 depth-1"><a href="https://www.pressherald.com/foodanddining/restaurant-reviews/">Restaurant reviews</a></li>
<li id="menu-item-2331616" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2331616 depth-1"><a href="https://www.pressherald.com/foodanddining/cookbook-reviews/">Cookbook Reviews</a></li>
<li id="menu-item-2331620" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2331620 depth-1"><a href="https://www.pressherald.com/foodanddining/recipes/">Recipes</a></li>
<li id="menu-item-2331624" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2331624 depth-1"><a href="https://www.pressherald.com/foodanddining/vegan-kitchen/">Vegan Kitchen</a></li>
<li id="menu-item-3105157" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3105157 depth-1"><a href="https://www.pressherald.com/source/green-plate-special/">Green Plate Special</a></li>
<li id="menu-item-3105145" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-3105145 depth-1"><a href="https://www.pressherald.com/source/maine-gardener/">Maine Gardener</a></li>
</ul>
</li>
<li id="menu-item-2331604" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-2331604 depth-0"><a href="https://www.pressherald.com/things-to-do/">Do This</a>
<ul class="sub-menu">
<li id="menu-item-2331608" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2331608 depth-1"><a href="https://www.pressherald.com/things-to-do/">All Do This</a></li>
<li id="menu-item-5451550" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5451550 depth-1"><a href="https://www.pressherald.com/news/events/maine-voices-live/">Maine Voices Live Events</a></li>
<li id="menu-item-5451578" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5451578 depth-1"><a href="https://www.pressherald.com/business-series/">Making It Work Events</a></li>
<li id="menu-item-5451582" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5451582 depth-1"><a href="https://www.pressherald.com/news/events/like-a-boss/">Like A Boss Events</a></li>
<li id="menu-item-5451554" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-5451554 depth-1"><a href="https://www.pressherald.com/news/events/">All PPH Events</a></li>
<li id="menu-item-3158311" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-3158311 depth-1"><a href="https://www.pressherald.com/things-to-do/guides/">Guides</a></li>
<li id="menu-item-1628594" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1628594 depth-1"><a href="https://www.pressherald.com/things-to-do/do-this-calendar/#!/">Event Calendar</a></li>
</ul>
</li>
<li id="menu-item-1201389" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1201389 depth-0"><a href="/obituaries/">Obits</a></li>
<li id="menu-item-1355827" class="single-col menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-1355827 depth-0"><a href="https://www.pressherald.com/realestate/">Homes</a>
<ul class="sub-menu">
<li id="menu-item-2462836" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2462836 depth-1"><a href="https://www.pressherald.com/realestate/">All Real Estate</a></li>
<li id="menu-item-2463028" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2463028 depth-1"><a target="_blank" rel="noopener" href="https://homes.pressherald.com/search">Homes for Sale</a></li>
<li id="menu-item-2632460" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-2632460 depth-1"><a href="https://homes.pressherald.com/search/open_house_dates=next_14_days">Open Houses</a></li>
<li id="menu-item-1355828" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1355828 depth-1"><a href="https://www.pressherald.com/realestate/places-to-love/">Maine Places to Love</a></li>
<li id="menu-item-1355829" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1355829 depth-1"><a href="https://www.pressherald.com/realestate/premier-property/">Premier Property</a></li>
</ul>
</li>
<li id="menu-item-5641856" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5641856 depth-0"><a href="http://mainejobs.com">Jobs</a></li>
<li id="menu-item-1201394" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1201394 depth-0"><a target="_blank" rel="noopener" href="http://www.mainenotices.com/?utm_source=pressherald.com&#038;utm_medium=referral&#038;utm_campaign=menu">Public Notices</a></li>
<li id="menu-item-5957361" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5957361 depth-0"><a href="https://www.pressherald.com/auto/">Auto</a></li>
</ul>
<div class="search-toggle">
<i class="fa fa-search" aria-hidden="true"></i>
</div>
<div class="subscribe-banner-btn">
<div class="fixed-subscribe-btn" id="MG2Subscribe" style="display:none;"><a href="https://www.pressherald.com/subscription-plans">Subscribe</a></div>
<div class="fixed-subscribe-btn" id="MG2MyAccount" style="display:none;"><a href="https://myaccount.pressherald.com" target="_blank">myAccount</a></div>
<div class="login-btn fixed-subscribe-btn" id="MG2Login" data-mg2-action="login" style="display:none;"><a href="#">Login</a></div>
<div class="login-btn fixed-subscribe-btn" id="MG2Logout" data-mg2-action="logout" style="display:none;"><a href="#">Log Out</a></div>
</div>
</div>
<div class="mtm-wrapper post-wrapper">
<div id="pos_1_atf_728x90-wrap" class="ad-wrapper"><div id="pos_1_atf_728x90" class="mtm-leaderboard-pos1"><script type="text/javascript">googletag.cmd.push(function(){googletag.display('pos_1_atf_728x90'); });</script></div></div>
<div class="main-content-wrap">
<div itemscope itemtype="http://schema.org/Article" class="article




				" id="js-mtm-article">
<header>
<a href="https://www.pressherald.com/times-record/times-record-obituaries/" class="category-wrapper">
<div class="category">
Times Record Obituaries </div>
</a>
<div class="timestamp">
<div class="posted">
Posted <time itemprop="datePublished" datetime="2022-04-21T01:01:01-04:00">1:01 AM</time>
</div>
</div>
<div class="font-resize">
<span>increase font size</span>
<img src="https://www.pressherald.com/wp-content/themes/mainetoday/assets/images/font-resize.png" alt="Resize Font" />
</div>
<h1 itemprop="headline"><span itemprop="mainEntityOfPage">Obituary: William E. Alexander Jr.</span></h1>
<p class="article-excerpt" itemprop="description">
William E. Alexander Jr. 1943 - 2022 ALBANY, N.Y. - William Ellsworth &quot;Alex&quot; Alexander, Jr. passed away suddenly of natural causes ...	</p>
</header>
<div class="mtm-article p402_premium">
<div class="article-social-sharing p402_hide print-no">
<div class="share-name">Share</div>
<div class="facebook social-button">
<a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.pressherald.com%2F2022%2F04%2F21%2Fobituarywilliam-e-alexander-jr%2F" target="_blank">
<img src="https://www.pressherald.com/wp-content/themes/mainetoday/assets/images/article-fb-icon.png" alt="facebook">
</a>
</div>
<div class="twitter social-button">
<a href="https://twitter.com/intent/tweet/?text=Obituary%3A+William+E.+Alexander+Jr.&amp;url=https%3A%2F%2Fwww.pressherald.com%2F%3Fp%3D6529775" target="_blank">
<img src="https://www.pressherald.com/wp-content/themes/mainetoday/assets/images/article-twitter-icon.png" alt="tweet">
</a>
</div>
<div class="reddit social-button">
<a href="http://www.reddit.com/submit?title=Obituary%3A+William+E.+Alexander+Jr.&amp;url=https%3A%2F%2Fwww.pressherald.com%2F%3Fp%3D6529775" target="_blank">
<img src="https://www.pressherald.com/wp-content/themes/mainetoday/assets/images/reddit-icon.png" alt="reddit">
</a>
</div>
<div class="email social-button">
<a href="/cdn-cgi/l/email-protection#af90dcdacdc5caccdb92e0cdc6dbdaceddd6958ff8c6c3c3c6cec28fea818feec3cad7cec1cbcadd8fe5dd8189cec2df94cdc0cbd692e9ddc0c28a9d9fffddcadcdc8fe7caddcec3cb8a9cee8a9d9fe0cdc6dbdaceddd6958ff8c6c3c3c6cec28fea818feec3cad7cec1cbcadd8fe5dd818a9fee8a9feec7dbdbdfdc8a9cee8a9de98a9de9d8d8d881dfddcadcdcc7caddcec3cb81ccc0c28a9de98a9ce9df8a9ceb999a9d9698989a">
<img src="https://www.pressherald.com/wp-content/themes/mainetoday/assets/images/article-email-icon.png" alt="email">
</a>
</div>
<div class="print social-button">
<a href="http://api.addthis.com/oexchange/0.8/forward/printfriendly/offer?title=&amp;pubid=ra-535983434d690928&amp;url=https%3A%2F%2Fwww.pressherald.com%2F2022%2F04%2F21%2Fobituarywilliam-e-alexander-jr%2F" target="_blank">
<img src="https://www.pressherald.com/wp-content/themes/mainetoday/assets/images/article-print-icon.png" alt="print">
</a>
</div>
</div>
<div class="post-content clearfix" itemprop="articleBody" id="js-post-content" data-truncate="3">
<p><div style='float:left;margin: 15px 20px 0 0;'><img src="https://www.pressherald.com/wp-content/plugins/lazy-load/images/1x1.trans.gif" data-lazy-src="https://multifiles.pressherald.com/uploads/sites/4/2022/04/0346734.jpg"><noscript><img src='https://multifiles.pressherald.com/uploads/sites/4/2022/04/0346734.jpg'></noscript></p>
<p class='wp-caption-text'>William E. Alexander Jr.</p><div class="inner-sidebar">
</div>
</div>
<p>William E. Alexander Jr. 1943 &#8211; 2022 ALBANY, N.Y. &#8211; William Ellsworth &#8220;Alex&#8221; Alexander, Jr. passed away suddenly of natural causes on Sunday, April 17, 2022 in Albany, N.Y. Born in 1943 in Brunswick, Maine, Alex was the son of the late William E. and Alice Emma (Bourassa) Alexander. Upon graduating high school in 1961, Alex enlisted in the US Air Force and became a Food Service Representative. He served during the Early Vietnam Era from 1961-1965. He started his career stationed in Grand Forks, N.D. and continued his service stationed at Incirlik Air Base in Turkey. Driven to continue his service to this great country, he decided to join the Minnesota National Guard in 1989. He served with a Signal Company and later with a Tank Battalion. He continued his service when he moved to Rochester, N.Y. in 2000. After moving to Albany and becoming part of a Maintenance Company, his division was sent to and spent weeks at Ground Zero immediately after 9/11. He completed his 20-year service record retiring from the military as a NY National Guard member in 2003. He believed that the most important commitment every citizen should make is to serve this great country in a branch of the military. Alex spent the last years of his life at the Ohav Shalom Apartments in Albany where he enjoyed reading Western novels, playing bingo and socializing at community meals. Alex is survived by his two daughters, Julie (Mark) Hallee and Justine (Mark) Criswell; his four grandchildren; and his brother, Albert Alexander. There are no public services scheduled at this time. Interment will take place at the Central Maine Veterans&#8217; Memorial Cemetery in Augusta, Maine. Arrangements have been entrusted by Alex&#8217;s family to the care of Dufresne &amp; Cavanaugh Funeral Home, Latham, N.Y. In lieu of flowers, memorial donations may be made in Alex&#8217;s memory to: The Wounded Warrior Project at <a href="https://support.woundedwarriorproject.org/" rel="nofollow">https://support.woundedwarriorproject.org/</a></p>
<div class="mobile-article-sidebar-wrapper">
<div class="mobile-article-sidebar-1"></div>
<div class="mobile-article-sidebar-2"></div>
</div>
<h3 id="guestbook ">Guest Book</h3>
<div class="fb-comments" data-href="https://www.pressherald.com/2022/04/21/obituarywilliam-e-alexander-jr/" data-width="" data-numposts="5"></div>
<div class="feedback no-print p402_hide">
<p>
<a href="/feedback-form/">Send questions/comments</a> to the editors.
</p>
</div>
<div class="clearfix"></div>


<div id='native_ad' class='no-print print-no'>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript'>
						googletag.cmd.push(function() { googletag.display('native_ad'); });
					</script>
</div>

<div class='no-print print-no'>
</div>
</div> 
</div> 

<script type="text/javascript">
					/*
					(function($, undefined){
					   'use strict';
					   $(init);
					   function init(){
						  if( /auth0_sub/i.test(document.cookie) ){
							 return;
						  }
						  try { _402_Show(); } catch(e) {}
					   }


					   return {};
					}(jQuery));
					*/
				</script>

<div class="mtm-ad-col-article" id="js-mtm-sidebar">
<ul class="widget-sidebar">
<li id="acm_ad_zones-10" class="widget acm_ad_zones"><div id="pos_2_atf_300x250-wrap" class="ad-wrapper"><div id="pos_2_atf_300x250" class="pos_2_atf_300x250"><script type="text/javascript">googletag.cmd.push(function(){googletag.display('pos_2_atf_300x250'); });</script></div></div></li>
<li id="gform_widget-33" class="widget gform_widget"><link rel='stylesheet' id='gforms_reset_css-css' href='https://www.pressherald.com/wp-content/plugins/gravityforms/legacy/css/formreset.min.css?ver=2.5.16.2' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_formsmain_css-css' href='https://www.pressherald.com/wp-content/plugins/gravityforms/legacy/css/formsmain.min.css?ver=2.5.16.2' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_ready_class_css-css' href='https://www.pressherald.com/wp-content/plugins/gravityforms/legacy/css/readyclass.min.css?ver=2.5.16.2' type='text/css' media='all' />
<link rel='stylesheet' id='gforms_browsers_css-css' href='https://www.pressherald.com/wp-content/plugins/gravityforms/legacy/css/browsers.min.css?ver=2.5.16.2' type='text/css' media='all' />
<style type="text/css">
					</style>
<script type='text/javascript' src='https://www.pressherald.com/wp-includes/js/dist/vendor/regenerator-runtime.min.js?ver=0.13.9' id='regenerator-runtime-js'></script>
<script type='text/javascript' src='https://www.pressherald.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=3.15.0' id='wp-polyfill-js'></script>
<script type='text/javascript' src='https://www.pressherald.com/wp-includes/js/dist/dom-ready.min.js?ver=ecda74de0221e1c2ce5c57cbb5af09d5' id='wp-dom-ready-js'></script>
<script type='text/javascript' src='https://www.pressherald.com/wp-includes/js/dist/hooks.min.js?ver=1e58c8c5a32b2e97491080c5b10dc71c' id='wp-hooks-js'></script>
<script type='text/javascript' src='https://www.pressherald.com/wp-includes/js/dist/i18n.min.js?ver=30fcecb428a0e8383d3776bcdd3a7834' id='wp-i18n-js'></script>
<script type='text/javascript' id='wp-i18n-js-after'>
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
</script>
<script type='text/javascript' id='wp-a11y-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script type='text/javascript' src='https://www.pressherald.com/wp-includes/js/dist/a11y.min.js?ver=68e470cf840f69530e9db3be229ad4b6' id='wp-a11y-js'></script>
<style type="text/css">
					</style>
<script type='text/javascript' defer='defer' src='https://www.pressherald.com/wp-content/plugins/gravityforms/js/jquery.json.min.js?ver=2.5.16.2' id='gform_json-js'></script>
<script type='text/javascript' id='gform_gravityforms-js-extra'>
/* <![CDATA[ */
var gform_i18n = {"datepicker":{"days":{"monday":"Mon","tuesday":"Tue","wednesday":"Wed","thursday":"Thu","friday":"Fri","saturday":"Sat","sunday":"Sun"},"months":{"january":"January","february":"February","march":"March","april":"April","may":"May","june":"June","july":"July","august":"August","september":"September","october":"October","november":"November","december":"December"},"firstDay":1,"iconText":"Select date"}};
var gf_global = {"gf_currency_config":{"name":"U.S. Dollar","symbol_left":"$","symbol_right":"","symbol_padding":"","thousand_separator":",","decimal_separator":".","decimals":2,"code":"USD"},"base_url":"https:\/\/www.pressherald.com\/wp-content\/plugins\/gravityforms","number_formats":[],"spinnerUrl":"https:\/\/www.pressherald.com\/wp-content\/plugins\/gravityforms\/images\/spinner.svg","strings":{"newRowAdded":"New row added.","rowRemoved":"Row removed","formSaved":"The form has been saved.  The content contains the link to return and complete the form."}};
/* ]]> */
</script>
<script type='text/javascript' defer='defer' src='https://www.pressherald.com/wp-content/plugins/gravityforms/js/gravityforms.min.js?ver=2.5.16.2' id='gform_gravityforms-js'></script>
<style type="text/css">
					</style>
<script type='text/javascript' id='gform_conditional_logic-js-extra'>
/* <![CDATA[ */
var gf_legacy = {"is_legacy":"1"};
/* ]]> */
</script>
<script type='text/javascript' defer='defer' src='https://www.pressherald.com/wp-content/plugins/gravityforms/js/conditional_logic.min.js?ver=2.5.16.2' id='gform_conditional_logic-js'></script>
<style type="text/css">
					</style>
<script type='text/javascript' defer='defer' src='https://www.google.com/recaptcha/api.js?hl=en&#038;ver=5.9.3#038;render=explicit' id='gform_recaptcha-js'></script>
<style type="text/css">
					</style>
<script type='text/javascript' defer='defer' src='https://www.pressherald.com/wp-content/plugins/gravityforms/js/placeholders.jquery.min.js?ver=2.5.16.2' id='gform_placeholder-js'></script>
<style type="text/css">
					</style>
<script type="text/javascript"></script>
<div class='gf_browser_unknown gform_wrapper dark_wrapper gform_legacy_markup_wrapper' id='gform_wrapper_737' style='display:none'><form method='post' enctype='multipart/form-data' id='gform_737' class='dark gform_legacy_markup' action='/2022/04/21/obituarywilliam-e-alexander-jr/'>
<div class='gform_body gform-body'><ul id='gform_fields_737' class='gform_fields top_label form_sublabel_below description_below'><li id="field_737_4" class="gfield gfield_html gfield_html_formatted gfield_no_follows_desc field_sublabel_below field_description_below gfield_visibility_visible"><h3 class="formtitle">Daily Headlines</h3>
<div class="formdetail">Sign up and get the top stories to begin the day delivered to your inbox at 5 a.m.</div>
</li><li id="field_737_1" class="gfield field_sublabel_below field_description_below gfield_visibility_visible"><label class='gfield_label screen-reader-text' for='input_737_1'>Email address</label><div class='ginput_container ginput_container_email'>
<input name='input_1' id='input_737_1' type='text' value='' class='large' placeholder='Email address' aria-invalid="false" />
</div></li><li id="field_737_5" class="gfield field_sublabel_below field_description_below gfield_visibility_visible"><label class='gfield_label screen-reader-text' for='input_737_5'></label><div id='input_737_5' class='ginput_container ginput_recaptcha' data-sitekey='6LcDi_YUAAAAALqTjCLPayWGW7yU3I4OZR0nNB2v' data-theme='light' data-tabindex='0' data-badge=''></div></li><li id="field_737_7" class="gfield field_sublabel_below field_description_below gfield_visibility_hidden"><div class='admin-hidden-markup'><i class='gform-icon gform-icon--hidden'></i><span>Hidden</span></div><label class='gfield_label' for='input_737_7'>Untitled</label><div class='ginput_container ginput_container_text'><input name='input_7' id='input_737_7' type='text' value='https://www.pressherald.com/2022/04/21/obituarywilliam-e-alexander-jr/' class='large' aria-invalid="false" /> </div></li><li id="field_737_8" class="gfield field_sublabel_below field_description_below gfield_visibility_hidden"><div class='admin-hidden-markup'><i class='gform-icon gform-icon--hidden'></i><span>Hidden</span></div><label class='gfield_label' for='input_737_8'>Untitled</label><div class='ginput_container ginput_container_text'><input name='input_8' id='input_737_8' type='text' value='Daily headlines inline' class='large' aria-invalid="false" /> </div></li><li id="field_737_9" class="gfield gform_validation_container field_sublabel_below field_description_below gfield_visibility_visible"><label class='gfield_label' for='input_737_9'>Phone</label><div class='ginput_container'><input name='input_9' id='input_737_9' type='text' value='' /></div><div class='gfield_description' id='gfield_description_737_9'>This field is for validation purposes and should be left unchanged.</div></li></ul></div>
<div class='gform_footer top_label'> <input type='submit' id='gform_submit_button_737' class='gform_button button' value='Submit' onclick='if(window["gf_submitting_737"]){return false;}  window["gf_submitting_737"]=true;  ' onkeypress='if( event.keyCode == 13 ){ if(window["gf_submitting_737"]){return false;} window["gf_submitting_737"]=true;  jQuery("#gform_737").trigger("submit",[true]); }' />
<input type='hidden' class='gform_hidden' name='is_submit_737' value='1' />
<input type='hidden' class='gform_hidden' name='gform_submit' value='737' />
<input type='hidden' class='gform_hidden' name='gform_unique_id' value='' />
<input type='hidden' class='gform_hidden' name='state_737' value='WyJbXSIsIjljZDljOTdiMWYwNDE1YjFjYTk1Y2UxOWM4NDk4MGUzIl0=' />
<input type='hidden' class='gform_hidden' name='gform_target_page_number_737' id='gform_target_page_number_737' value='0' />
<input type='hidden' class='gform_hidden' name='gform_source_page_number_737' id='gform_source_page_number_737' value='1' />
<input type='hidden' name='gform_field_values' value='' />
</div>
</form>
</div></li>
<li id="acm_ad_zones-6" class="widget acm_ad_zones"><div id="pos_3_btf_300x250_300x600-wrap" class="ad-wrapper"><div id="pos_3_btf_300x250_300x600"><script type="text/javascript">googletag.cmd.push(function(){googletag.display('pos_3_btf_300x250_300x600'); });</script></div></div></li>
<div id="most-read-single">
<div class="featured-header">
Most Read Stories </div>
<div id="most-read-box">
<ul>
<li>
<h3>
<a href="https://www.pressherald.com/2022/04/20/maine-resident-dies-from-tick-borne-illness/">
Maine resident dies from tick-borne illness </a>
</h3>
</li>
<li>
<h3>
<a href="https://www.pressherald.com/2022/04/19/covid-19-hospitalizations-increase/">
COVID-19 hospitalizations increase in Maine </a>
</h3>
</li>
<li>
<h3>
<a href="https://www.pressherald.com/2022/04/19/as-more-people-arrive-in-portland-in-need-of-shelter-the-city-is-seeking-help-farther-afield/">
As more people arrive in Portland in need of shelter, the city seeks help farther afield </a>
</h3>
</li>
<li>
<h3>
<a href="https://www.pressherald.com/2022/04/19/bowdoin-president-stepping-down/">
Bowdoin College president Clayton Rose stepping down after 8 years </a>
</h3>
</li>
<li>
<h3>
<a href="https://www.pressherald.com/2022/04/19/lawmakers-give-initial-approval-to-1-2-billion-state-budget/">
Maine lawmakers approve $1.2 billion state budget </a>
</h3>
</li>
</ul>
</div>
</div>
<li id="acm_ad_zones-11" class="widget acm_ad_zones"><div id="pos_btf_8_300x250-wrap" class="ad-wrapper"><div id="pos_btf_8_300x250"><script type="text/javascript">googletag.cmd.push(function(){googletag.display('pos_btf_8_300x250'); });</script></div></div></li>
<li id="acm_ad_zones-79" class="widget acm_ad_zones"></li>
<li id="text-12" class="widget widget_text"> <div class="textwidget"><script>


jQuery(function(){
if (jQuery(".article-sidebar").length <= 0){
  jQuery(".photo-store").hide();
}
});
</script>
<style>

@media screen and (max-width: 800px){
.mtm-article .font-resize, .mtm-article-full-width .font-resize {
 display: block; 
  position: absolute;
  margin-top: -70px;
  right: 20px;
}
}
.article-sidebar{
clear:both;
}
.mtm-article .main-asset .image-crop{
clear:both;
}

@media screen and (max-width: 532px) {
  .print.social-button {
display:none;
}
}

.article-social-sharing{
height:15px;
}



</style>
</div>
</li>
</ul>
</div>
</div> 
</div>
</div> 
</div> 
<div class="mtm-footer active-widgets">
<div class="mtm-footer-inner">
<div class="TopPart">
<div class="footer-logo">
<img width="225" height="40" src="https://www.pressherald.com/wp-content/themes/mainetoday-pressherald/assets/images/tr-footer.png" />
</div>
<div class="footer-logo-white">
<div class="mtm-mobile-footer-menu"></div>
<img src="" alt="Times Record" />
</div>
<div class="mtm-footer-social__links">
<div class="social">
<a href="https://www.facebook.com/TheTimesRecord" target="_blank"><img src="https://www.pressherald.com/wp-content/themes/mainetoday/assets/images/fb-reverse.png" alt="facebook" /></a>
<a href="https://twitter.com/MidcoastNews" target="_blank"><img src="https://www.pressherald.com/wp-content/themes/mainetoday/assets/images/tw-reverse.png" alt="twitter" /></a>
</div>
</div>
</div>
<div class="footer-widgets clearfix">
<div id="nav_menu-19" class="widget widget_nav_menu"><h2 class="widgettitle">Contact</h2>
<div class="menu-times-record-contact-footer-container"><ul id="menu-times-record-contact-footer" class="menu"><li id="menu-item-5955501" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5955501 depth-0"><a href="https://www.pressherald.com/times-record-staff-directory/#parentVerticalTab2">Staff Directory</a></li>
<li id="menu-item-5955504" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5955504 depth-0"><a href="https://www.pressherald.com/times-record-news-tips/">Send a Story Tip</a></li>
<li id="menu-item-5955840" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5955840 depth-0"><a href="https://www.pressherald.com/times-record-letters-to-the-editor/">Send a Letter to the Editor</a></li>
<li id="menu-item-5955585" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5955585 depth-0"><a href="https://www.pressherald.com/times-record-staff-directory/#parentVerticalTab5">FAQs</a></li>
</ul></div></div><div id="nav_menu-14" class="widget widget_nav_menu"><h2 class="widgettitle">Advertise</h2>
<div class="menu-times-record-advertise-footer-container"><ul id="menu-times-record-advertise-footer" class="menu"><li id="menu-item-5955666" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5955666 depth-0"><a href="http://masthead.me/">Media Kit</a></li>
<li id="menu-item-5955669" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5955669 depth-0"><a href="https://www.pressherald.com/times-record-staff-directory/#parentVerticalTab3">Contact Advertising</a></li>
<li id="menu-item-5955678" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5955678 depth-0"><a href="https://www.pressherald.com/contact/#place-obit">Place an Obituary</a></li>
</ul></div></div><div id="nav_menu-18" class="widget widget_nav_menu"><h2 class="widgettitle">Products</h2>
<div class="menu-times-record-products-footer-container"><ul id="menu-times-record-products-footer" class="menu"><li id="menu-item-5955612" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5955612 depth-0"><a href="https://www.pressherald.com/trheadlines/">Daily Headlines Newsletter</a></li>
<li id="menu-item-5955615" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5955615 depth-0"><a href="https://www.pressherald.com/times-record-epaper/">ePaper</a></li>
<li id="menu-item-5956428" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5956428 depth-0"><a href="https://www.pressherald.com/trepaperdelivery/">ePaper Delivery Alert</a></li>
<li id="menu-item-5955621" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5955621 depth-0"><a href="https://www.pressherald.com/times-record-mobile-products/">Mobile Apps</a></li>
</ul></div></div><div id="nav_menu-15" class="widget widget_nav_menu"><h2 class="widgettitle">Connect</h2>
<div class="menu-times-record-connect-footer-container"><ul id="menu-times-record-connect-footer" class="menu"><li id="menu-item-5955399" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5955399 depth-0"><a href="https://www.facebook.com/TheTimesRecord">Facebook</a></li>
<li id="menu-item-5955402" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5955402 depth-0"><a href="https://twitter.com/MidcoastNews">Twitter</a></li>
<li id="menu-item-5955405" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5955405 depth-0"><a href="https://twitter.com/SportsMidcoast">Sports Twitter</a></li>
</ul></div></div><div id="nav_menu-17" class="widget widget_nav_menu"><h2 class="widgettitle">Subscribers</h2>
<div class="menu-times-record-subscribe-footer-container"><ul id="menu-times-record-subscribe-footer" class="menu"><li id="menu-item-6413066" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6413066 depth-0"><a href="https://subscribe.timesrecord.com/">Subscribe</a></li>
<li id="menu-item-6413072" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6413072 depth-0"><a href="https://myaccount.timesrecord.com/amg_tr/home">Manage Your Account</a></li>
<li id="menu-item-6413069" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6413069 depth-0"><a href="https://myaccount.timesrecord.com/amg_tr/complaint">Log a Delivery Issue</a></li>
<li id="menu-item-5955702" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5955702 depth-0"><a href="https://www.pressherald.com/trbenefits/">Subscriber Benefits</a></li>
</ul></div></div><div id="nav_menu-16" class="widget widget_nav_menu"><h2 class="widgettitle">Masthead Maine Network</h2>
<div class="menu-times-record-network-footer-container"><ul id="menu-times-record-network-footer" class="menu"><li id="menu-item-5955462" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5955462 depth-0"><a href="https://www.centralmaine.com/">Centralmaine.com</a></li>
<li id="menu-item-5955465" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-5955465 depth-0"><a href="https://www.pressherald.com/">Pressherald.com</a></li>
<li id="menu-item-5955468" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5955468 depth-0"><a href="https://www.sunjournal.com/">Sunjournal.com</a></li>
<li id="menu-item-5955471" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5955471 depth-0"><a href="https://www.pressherald.com/forecaster/">The Forecasters</a></li>
<li id="menu-item-5955474" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5955474 depth-0"><a href="https://www.pressherald.com/mainely-media/">Mainely Media Weeklies</a></li>
<li id="menu-item-5955477" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5955477 depth-0"><a href="http://varsitymaine.com/">Varsity Maine</a></li>
<li id="menu-item-5956410" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5956410 depth-0"><a href="https://www.pressherald.com/signature-events/">Masthead Maine Events</a></li>
</ul></div></div><div id="custom_html-145" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><style>
.pos_MR_185x90, .pos_ML_185x90{
		margin-top:50px;
		
	}
		
@media only screen and (max-width: 600px)  {
		.tr-logo{display:none  !important;}
}
	</style>
</div></div> </div>
<div class="Copyright footer-menu">
<div class="menu-section-footer-container"><ul id="menu-section-footer" class="menu"><li id="menu-item-1215382" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-1215382 depth-0"><a href="https://www.pressherald.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-1384325" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1384325 depth-0"><a href="https://www.pressherald.com/cookie-policy/">Cookie Policy</a></li>
<li id="menu-item-3196443" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3196443 depth-0"><a href="https://www.pressherald.com/terms-service/">Terms of Service</a></li>
<li id="menu-item-3196439" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-3196439 depth-0"><a href="https://www.pressherald.com/commenting-terms/">Commenting Terms</a></li>
<li id="menu-item-1215386" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1215386 depth-0"><a href="http://www.mainenotices.com/">Public Notices</a></li>
<li id="menu-item-1215392" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1215392 depth-0"><a href="https://www.pressherald.com/buyphotos/">Photo Store</a></li>
<li id="menu-item-6338558" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6338558 depth-0"><a href="https://store.masthead.me">Merch Store</a></li>
<li id="menu-item-6169761" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-6169761 depth-0"><a href="https://pressherald.newsbank.com/">Archive Search</a></li>
</ul></div> </div>
</div>
</div>
<div class="mtm-footer-social">
<div class="mtm-footer-social__copyright">
<span class="copyright">&copy; 2022</span>
| <span class="rights">All Rights Reserved</span>
| <strong class="blog-name">Press Herald</strong>


</div>
</div>
<div id='posfHolder'>
<div id="fCloseBtn">X</div>
<div id="pos_f_320x50">
<script>
 googletag.cmd.push(function() { googletag.display('pos_f_320x50'); });
</script>
</div>
</div>
<div class="mtm-login-skin" style="">
</div>
<script type='text/javascript' src='https://www.pressherald.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery-ui/core.min.js?ver=1.11.4-wp' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://www.pressherald.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery-ui/widget.min.js?ver=1.11.4-wp' id='jquery-ui-widget-js'></script>
<script type='text/javascript' src='https://www.pressherald.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery-ui/tabs.min.js?ver=1.11.4-wp' id='jquery-ui-tabs-js'></script>
<script type='text/javascript' src='https://www.pressherald.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery-ui/effect.min.js?ver=1.11.4-wp' id='jquery-effects-core-js'></script>
<script type='text/javascript' src='https://www.pressherald.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery-ui/effect-slide.min.js?ver=1.11.4-wp' id='jquery-effects-slide-js'></script>
<script type='text/javascript' src='https://www.pressherald.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery-ui/position.min.js?ver=1.11.4-wp' id='jquery-ui-position-js'></script>
<script type='text/javascript' src='https://www.pressherald.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery-ui/menu.min.js?ver=1.11.4-wp' id='jquery-ui-menu-js'></script>
<script type='text/javascript' id='jquery-ui-autocomplete-js-extra'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.pressherald.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery-ui/autocomplete.min.js?ver=1.11.4-wp' id='jquery-ui-autocomplete-js'></script>
<script type='text/javascript' id='mtm-js-extra'>
/* <![CDATA[ */
var MTMMailChimp = {"nonce":"85e3579ea5","action":"mtm_mailchimp_subscribe","ajaxurl":"https:\/\/www.pressherald.com\/wp-admin\/admin-ajax.php"};
var mtmSettings = {"isSingular":"true","isHome":"false","isComments":"false","url":"https:\/\/www.pressherald.com","restrictedComments":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.pressherald.com/wp-content/themes/mainetoday/assets/js/mainetoday.min.js?ver=1649941855' id='mtm-js'></script>
<script type='text/javascript' src='https://www.pressherald.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery-ui/datepicker.min.js?ver=1.11.4-wp' id='jquery-ui-datepicker-js'></script>
<script type='text/javascript' id='jquery-ui-datepicker-js-after'>
jQuery(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript' src='https://www.pressherald.com/wp-content/themes/mainetoday/assets/js/mtm-datepicker.js?ver=1.0' id='mtm-datepicker-js'></script>
<script type='text/javascript' src='https://www.pressherald.com/wp-includes/js/underscore.min.js?ver=1.13.1' id='underscore-js'></script>
<script type='text/javascript' id='wp-util-js-extra'>
/* <![CDATA[ */
var _wpUtilSettings = {"ajax":{"url":"\/wp-admin\/admin-ajax.php"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.pressherald.com/wp-includes/js/wp-util.min.js?ver=5.9.3' id='wp-util-js'></script>
<script type='text/javascript' src='https://www.pressherald.com/wp-content/themes/mainetoday/assets/js/obits-search.js?ver=1641305412' id='obits-search-js'></script>
<script type='text/javascript' src='https://www.pressherald.com/wp-content/themes/mainetoday/assets/js/vendor/prebid.js?ver=1611861787' id='ad-prebid-js'></script>
<script type='text/javascript' id='elasticpress-autosuggest-js-extra'>
/* <![CDATA[ */
var epas = {"query":"{\"from\":0,\"size\":10,\"sort\":[{\"_score\":{\"order\":\"desc\"}}],\"query\":{\"bool\":{\"should\":[{\"bool\":{\"must\":[{\"bool\":{\"should\":[{\"multi_match\":{\"query\":\"ep_autosuggest_placeholder\",\"type\":\"phrase\",\"fields\":[\"post_title^1\",\"post_excerpt^1\",\"post_content^1\",\"post_author.display_name^1\",\"terms.post_tag.name^1\",\"terms.category.name^1\",\"terms.ep_custom_result.name^9999\",\"post_title.suggest^1\",\"term_suggest^1\"],\"boost\":5,\"slop\":5}}]}}],\"filter\":[{\"match\":{\"post_type.raw\":\"post\"}}]}},{\"bool\":{\"must\":[{\"bool\":{\"should\":[{\"multi_match\":{\"query\":\"ep_autosuggest_placeholder\",\"type\":\"phrase\",\"fields\":[\"post_title^1\",\"post_excerpt^1\",\"post_content^1\",\"post_author.display_name^1\",\"terms.category.name^1\",\"terms.ep_custom_result.name^9999\",\"post_title.suggest^1\",\"term_suggest^1\"],\"boost\":5,\"slop\":5}}]}}],\"filter\":[{\"match\":{\"post_type.raw\":\"page\"}}]}},{\"bool\":{\"must\":[{\"bool\":{\"should\":[{\"multi_match\":{\"query\":\"ep_autosuggest_placeholder\",\"type\":\"phrase\",\"fields\":[\"post_title^1\",\"post_excerpt^1\",\"post_content^1\",\"post_author.display_name^1\",\"terms.post_tag.name^1\",\"terms.category.name^1\",\"terms.ep_custom_result.name^9999\",\"post_title.suggest^1\",\"term_suggest^1\"],\"boost\":5,\"slop\":5}}]}}],\"filter\":[{\"match\":{\"post_type.raw\":\"mtm_asset\"}}]}},{\"bool\":{\"must\":[{\"bool\":{\"should\":[{\"multi_match\":{\"query\":\"ep_autosuggest_placeholder\",\"type\":\"phrase\",\"fields\":[\"post_title^1\",\"post_excerpt^1\",\"post_content^1\",\"post_author.display_name^1\",\"terms.post_tag.name^1\",\"terms.category.name^1\",\"terms.ep_custom_result.name^9999\",\"post_title.suggest^1\",\"term_suggest^1\"],\"boost\":5,\"slop\":5}}]}}],\"filter\":[{\"match\":{\"post_type.raw\":\"mtm_interactive\"}}]}}]}},\"post_filter\":{\"bool\":{\"must\":[{\"terms\":{\"post_type.raw\":[\"post\",\"page\",\"mtm_asset\",\"mtm_interactive\"]}},{\"term\":{\"post_status\":\"publish\"}}]}}}","placeholder":"ep_autosuggest_placeholder","endpointUrl":"https:\/\/mtm2prod.clients.hosted-elasticpress.io\/mtm2prod-pressheraldcom-post-4\/autosuggest","selector":"ep-autosuggest","defaultSelectors":".ep-autosuggest, input[type=\"search\"], .search-field","action":"navigate","mimeTypes":[],"http_headers":[],"triggerAnalytics":"","addSearchTermHeader":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.pressherald.com/wp-content/plugins/elasticpress/dist/js/autosuggest-script.min.js?ver=3.6.6' id='elasticpress-autosuggest-js'></script>
<script type='text/javascript' src='https://www.pressherald.com/wp-content/plugins/lazy-load/js/jquery.sonar.min.js?ver=0.7' id='jquery-sonar-js'></script>
<script type='text/javascript' src='https://www.pressherald.com/wp-content/plugins/lazy-load/js/lazy-load.js?ver=0.7' id='wpcom-lazy-load-images-js'></script>
<script type='text/javascript' src='https://www.pressherald.com/wp-content/themes/mainetoday-pressherald/assets/js/mtm-child.min.js?ver=1641305412' id='mainetoday_pressherald-js'></script>
<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.9.3' async='async' id='remote_sdk-js'></script>
<script type="text/javascript">
gform.initializeOnLoaded( function() { jQuery(document).on('gform_post_render', function(event, formId, currentPage){if(formId == 737) {gf_global["number_formats"][737] = {"4":{"price":false,"value":false},"1":{"price":false,"value":false},"5":{"price":false,"value":false},"7":{"price":false,"value":false},"8":{"price":false,"value":false},"9":{"price":false,"value":false}};if(window['jQuery']){if(!window['gf_form_conditional_logic'])window['gf_form_conditional_logic'] = new Array();window['gf_form_conditional_logic'][737] = { logic: { 5: {"field":{"actionType":"show","logicType":"all","rules":[{"fieldId":"1","operator":"contains","value":"@"}],"enabled":true},"nextButton":null,"section":null} }, dependents: { 5: [5] }, animation: 0, defaults: {"7":"https:\/\/www.pressherald.com\/2022\/04\/21\/obituarywilliam-e-alexander-jr\/","8":"Daily headlines inline"}, fields: {"4":[],"1":[5],"5":[],"7":[],"8":[],"9":[]} }; if(!window['gf_number_format'])window['gf_number_format'] = 'decimal_dot';jQuery(document).ready(function(){window['gformInitPriceFields']();gf_apply_rules(737, [5], true);jQuery('#gform_wrapper_737').show();jQuery(document).trigger('gform_post_conditional_logic', [737, null, true]);} );} if(typeof Placeholders != 'undefined'){
                        Placeholders.enable();
                    }} } );jQuery(document).bind('gform_post_conditional_logic', function(event, formId, fields, isInit){} ) } );
</script>
<script type="text/javascript">
gform.initializeOnLoaded( function() { jQuery(document).trigger('gform_post_render', [737, 1]) } );
</script>
<script type="text/javascript">

    var user_state = "none";
    var isStage = /^stage/.test(window.location.host);
    var prodstate = "prod";
    var clientid = "wmQ0v7N8FtL1tuoKt1DyaiWWXiBdIY9E";
    var authdomain = "masthead-prod.us.auth0.com";
    var mgdebug = "false";

    var isStage = /^stage/.test(window.location.host);

    if (isStage){
      prodstate = "stage";
      authdomain = "masthead-dev.us.auth0.com";
          clientid = "5WiYKtonkjcXXSSh7iMCyjYtqP42wt4l";
          mgdebug = "true"; 
    }

    MG2Loader.init({
      plugins: [{
        name: "FP",
        initOptions: {
          version: "masthead",
          environment: prodstate
        }
      }, {
        name: "DL",
        initOptions: {
          version: "masthead",
          collectors: ["connext"],
          tagManager: "GTM",
          containerId: "GTM-WKNP65V"
        }
      }, {
        name: "NXT",
        initOptions: {
          clientCode: "masthead",
          environment: prodstate,
          siteCode: "PH",
          configCode: "PH_config",
          settingsKey: "MTM_PT",
          checkUserDataEveryPageload: true,
          debug: mgdebug,
          silentmode: true,
          authSettings: {
            domain: authdomain,
            client_id: clientid,
            redirect_uri: "https://"+location.host+"/success",
          },
          publicEventHandlers: {
            onNotAuthorized: function(eventData) {
              var now = new Date();
              
              user_state = "loggedout";
        
              jQuery('[id="MG2Login"]').show();
              jQuery('[id="MG2Subscribe"]').show();
              jQuery('[id="MG2MyAccount"]').hide();
              jQuery('[id="MG2Logout"]').hide();

            },
            onAuthorized: function(eventData) {
              user_state = "registered";


              jQuery('[id="MG2Login"]').hide();
              jQuery('[id="MG2Subscribe"]').show();
              jQuery('[id="MG2MyAccount"]').hide();
              jQuery('[id="MG2Logout"]').show();
              
            },
            onHasNoActiveSubscription: function(eventData) {
              user_state = "inactive";

              jQuery('[id="MG2Login"]').hide();
              jQuery('[id="MG2Subscribe"]').show();
              jQuery('[id="MG2MyAccount"]').hide();
              jQuery('[id="MG2Logout"]').show();

            },
            onHasAccessNotEntitled: function(eventData) {
              user_state = "notentitled";
              //not used  
              jQuery('[id="MG2Login"]').show();
              jQuery('[id="MG2Subscribe"]').show();
              jQuery('[id="MG2MyAccount"]').hide();
              jQuery('[id="MG2Logout"]').hide();

            },
            onHasAccess: function(eventData) {
              user_state = "subscribed";

              jQuery('[id="MG2Login"]').hide();
              jQuery('[id="MG2Subscribe"]').hide();
              jQuery('[id="MG2MyAccount"]').show();
              jQuery('[id="MG2Logout"]').show();

          
            }
          }
        }
      }]
    });

  </script>
<script type='text/javascript'>
      var _sf_async_config = _sf_async_config || {};
      /** CONFIGURATION START **/
       _sf_async_config.sections= 'obituaries,times-record,times-record-obituaries';
      _sf_async_config.authors = Utils.getAuthor();

      var _cbq = window._cbq = (window._cbq || []);
      _cbq.push(['_acct', (document.cookie.match(/auth0_sub/i) ? 'paid' : 'anon')]);

      /** CONFIGURATION END **/
      (function() {
          function loadChartbeat() {
              window._sf_endpt = (new Date()).getTime();
              var e = document.createElement('script');
              e.setAttribute('language', 'javascript');
              e.setAttribute('type', 'text/javascript');
              e.setAttribute('src', '//static.chartbeat.com/js/chartbeat.js');

              document.body.appendChild(e);
          }
          var oldonload = window.onload;
          window.onload = (typeof window.onload != 'function') ?
              loadChartbeat : function() {
                  oldonload();
                  loadChartbeat();
              };

          })();
      </script>
<script type="text/javascript">(function(){window['__CF$cv$params']={r:'6ff41a6d7d8c9c7e',m:'ka3_h6JgITcqWYIXRq59C2.Ig8_EEgdakk2e2yWEjf0-1650522964-0-AfggZ4r0EBx3V33W0+3f5YLsAqZGXFcXA9nGfSd7bRwLpCpOSdrL13BLJyQR/vLPKWBZETZK5WmMo+JYMCZuN/UtIK/UK3V/h4UcI9jqsUFwWtJW36EEeSpEkun/GuejQ3zttGeSRrQkr/hsIVXlpA+OsJej/r+6M5tMcY3ZKN8a',s:[0xc3f1b3d01f,0x6ec66f564c],u:'/cdn-cgi/challenge-platform/h/b'}})();</script></body>
</html>
<script type="text/javascript">
	  (function(e,t,o,n,p,r,i){e.visitorGlobalObjectAlias=n;e[e.visitorGlobalObjectAlias]=e[e.visitorGlobalObjectAlias]||function(){(e[e.visitorGlobalObjectAlias].q=e[e.visitorGlobalObjectAlias].q||[]).push(arguments)};e[e.visitorGlobalObjectAlias].l=(new Date).getTime();r=t.createElement("script");r.src=o;r.async=true;i=t.getElementsByTagName("script")[0];i.parentNode.insertBefore(r,i)})(window,document,"https://diffuser-cdn.app-us1.com/diffuser/diffuser.js","vgo");
	  vgo('setAccount', '476767297');
	  vgo('setTrackByDefault', true);

	  vgo('process');
	</script>
</body>
</html>